Frogger(Floyd算法)

简介: Frogger(Floyd算法)

题目:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

解题思路:

题上说从青蛙A不能直接到青蛙B,只能从其他的点去跳跃过去,如果A从其他点到B的每次距离都比A到B跳跃距离小的话,就输出其他点中的最大的边,否则直接输出A到B的距离,这个距离就是样例给的点的坐标,根据坐标利用两点之间的距离公式。

程序代码:

#include<stdio.h>
#include<math.h>
int sum;
int juli(int a,int b,int c,int d)
{
  return sum=(c-a)*(c-a)+(d-b)*(d-b);
}
int main()
{
  int n,cas=1;
  int e[500][500],dis[500],i,j,m,t1,t2,min,a,x[500],y[500],k;
  int inf=99999999;
  while(scanf("%d",&n),n!=0)
  {
    for(i=1;i<=n;i++)
      for(j=1;j<=n;j++)
        if(i==j)  e[i][j]=0;
        else   e[i][j]=inf;
    for(i=1;i<=n;i++)
      scanf("%d %d",&x[i],&y[i]);
    for(i=1;i<n;i++)
      for(j=i+1;j<=n;j++)
        e[i][j]=e[j][i]=juli(x[i],y[i],x[j],y[j]);
    for(k=1;k<=n;k++)
      for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
          if(e[i][k]>e[k][j])
            a=e[i][k];
          else
            a=e[k][j];
          if(e[i][j]>a)
            e[i][j]=a;
        } 
    printf("Scenario #%d\n",cas++);
    printf("Frog Distance = %.3lf\n",sqrt(e[1][2]));
    printf("\n");
    
  }
  return 0;
}
 


相关文章
|
4月前
|
算法
最短路之Floyd算法
最短路之Floyd算法
33 1
|
5月前
|
算法
Floyd 最短路径【学习算法】
Floyd 最短路径【学习算法】
31 0
|
6月前
|
算法
Floyd算法的应用
Floyd算法的应用
34 0
|
5月前
|
算法
floyd算法
floyd算法
|
10月前
|
算法
【路径规划】基于Dijkstra算法及Floyd算法的通信与网络路径规划(Matlab代码实现)
【路径规划】基于Dijkstra算法及Floyd算法的通信与网络路径规划(Matlab代码实现)
|
11月前
|
算法
转:用一个例子说明Floyd算法
弗洛伊德算法(Floyd&#39;s algorithm)是一种用于求带权图中最短路径的算法,适用于带有正负权边的图(但不能有负环)。这种算法也有时被称为弗洛伊德-沃尔什算法。该算法基于动态规划,其时间复杂度为O(V^3),其中V是图中的顶点数。此外,该算法还可用于检测图中的负环并求出传递闭包。
86 2
|
11月前
|
算法
最短路径——Floyd算法
最短路径——Floyd算法
|
11月前
|
机器学习/深度学习 传感器 编解码
【路径规划】基于A星算法结合floyd和动态窗口法实现机器人栅格地图路径规划附matlab代码
【路径规划】基于A星算法结合floyd和动态窗口法实现机器人栅格地图路径规划附matlab代码
|
12月前
|
算法
大话数据结构--弗洛伊德(Floyd)算法
大话数据结构--弗洛伊德(Floyd)算法
82 0
大话数据结构--弗洛伊德(Floyd)算法
|
12月前
|
机器学习/深度学习 存储 算法
搜索与图论 - floyd 算法
搜索与图论 - floyd 算法