HDOJ 1163 Eddy's digital Roots(九余数定理的应用)

简介: HDOJ 1163 Eddy's digital Roots(九余数定理的应用)

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.


For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.


The Eddy’s easy problem is that : give you the n,want you to find the n^n’s digital Roots.


Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).


Output

Output n^n’s digital root on a separate line of the output.


Sample Input

2

4

0


Sample Output

4

4


题意:输入一个数n,求n的n次方的数根。

数根:即某数字的每一位上的数字之和,如果和大于等于10,重复每一位上的数字之和,直到每一位上的数字之和是个位数。则这个个位数就是这个数字的数根。


九余数定理:

一个数对九取余,得到的数称之为九余数;

一个数的九余数 等于 它的各个数位上的数之和的九余数!

例:

5^5=3125

3+1+2+5=11

1+1=2(digital Roots)

3125%9=2;

一个数对9取余就等于它的个位数字之和对9取余就等于数根对9取余。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0){
                return ;
            }
            int m = 1;
            for(int i=0;i<n;i++){
                m=(m*n)%9;
            }
            if(m==0){
                System.out.println(9);
            }else{
                System.out.println(m);
            }
        }
    }
}
目录
打赏
0
0
0
0
988
分享
相关文章
UVa10484 - Divisibility of Factors(数论)
UVa10484 - Divisibility of Factors(数论)
116 1
【算法合集】深搜广搜Prim与Kruskal
广度优先搜索(BFS)又叫广搜,它像一个有远见的人,它是一层一层来实现搜索的,也挺像下楼梯的。 思路: 1.先初始化队列 q; 2.从起点开始访问,并且改变他的状态为已经访问; 3.如果他的队列非空,取出首个元素,将它弹出! 4.如果u == 目标状态,然后对所以与 u 邻近的点进入队列; 5.标记它已经被访问!...............
214 1
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
104 0
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
HDOJ 1013题Digital Roots 大数,9余数定理
HDOJ 1013题Digital Roots 大数,9余数定理
163 0
AI助理

你好,我是AI助理

可以解答问题、推荐解决方案等