HDU-1013,Digital Roots

简介: HDU-1013,Digital Roots

Problem Description:


The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.


For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.


Input:


The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.


Output:


For each integer in the input, output its digital root on a separate line of the output.


Sample Input:


24


39


0


Sample Output:


6


3


解题思路:


把每个数当做字符串去存入,然后把每个数位上的数相加,如果和小于10就直接输出,如果大于10,继续进行上述操作即可!


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
  string s;
  while(cin>>s&&s!="0")
  {
    long long d=0,x;
    for(int i=0;i<s.length();i++)
    {
      d+=s[i]-'0';
      while(d>=10)
      {
        x=d;
        d=0;
        while(x)
        {
          d+=x%10;
          x/=10;
        }
      }
    }
    printf("%lld\n",d);
  }
  return 0;
}


相关文章
|
机器学习/深度学习 C++
【PAT甲级 - C++题解】1094 The Largest Generation
【PAT甲级 - C++题解】1094 The Largest Generation
63 0
AtCoder Beginner Contest 133 E - Virus Tree 2(组合数学)
AtCoder Beginner Contest 133 E - Virus Tree 2(组合数学)
96 0
UVA439-骑士的移动 Knight Moves(BFS)
UVA439-骑士的移动 Knight Moves(BFS)
UVA439-骑士的移动 Knight Moves(BFS)
HDOJ 1013 Digital Roots
HDOJ 1013 Digital Roots
107 0
|
机器学习/深度学习
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
103 0
|
前端开发 网络架构
HDU-1049 Climbing Worm
HDU-1049 Climbing Worm
|
测试技术
Knight Moves(骑士移动) (bfs) POJ-2243
题目:Knight Moves (骑士移动)
|
机器学习/深度学习