HDU1163 Eddy's digital Roots【九剩余定理】

简介:

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4436    Accepted Submission(s): 2505


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
 
 
2 4 0
 

Sample Output
 
 
4 4
 

Author
eddy

九余数定理:一个数对9取余所得为九余数。一个数的九余数等于该数的各位和对9取余。

#include <stdio.h>

int main()
{
    int n, i, ans;
    while(scanf("%d", &n), n){
        ans = 1;
        for(i = 1; i <= n; ++i)
            ans = n * ans % 9;
        if(!ans) ans = 9;
        printf("%d\n", ans);
    }
    return 0;
}


版权声明:本文博主原创文章,博客,未经同意不得转载。







本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4916221.html,如需转载请自行联系原作者


相关文章
|
7月前
|
人工智能 算法 BI
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
UVa10484 - Divisibility of Factors(数论)
UVa10484 - Divisibility of Factors(数论)
64 1
|
C++
【PAT甲级 - C++题解】1108 Finding Average
【PAT甲级 - C++题解】1108 Finding Average
75 0
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem J. number sequence
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem J. number sequence
134 0
|
机器学习/深度学习
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
109 0
|
机器学习/深度学习
HDOJ 1013题Digital Roots 大数,9余数定理
HDOJ 1013题Digital Roots 大数,9余数定理
138 0
【1150】Travelling Salesman Problem (25分)【图论】
【1150】Travelling Salesman Problem (25分)【图论】 【1150】Travelling Salesman Problem (25分)【图论】
94 0
|
Java
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
102 0
|
机器学习/深度学习