HDOJ 1013题Digital Roots 大数,9余数定理

简介: HDOJ 1013题Digital Roots 大数,9余数定理

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.


For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.


Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.


Output

For each integer in the input, output its digital root on a separate line of the output.


Sample Input

 


  24

39

0

 

Sample Output

 


  6

3

 



一个数对九取余,得到的数称之为九余数;

一个数的九余数等于它的各个数位上的数之和的九余数!


题目大意:

给定一个正整数,根据一定的规则求出该数的“数根”,其规则如下:

       例如给定 数字 24,将24的各个位上的数字“分离”,分别得到数字 2 和 4,而2+4=6;

       因为 6 < 10,所以就认为6是数字24的“数根”;

       而对于数字 39 , 将39的各个位上的数字“分离”,分别得到数字 3 和 9,而3+9=12,且12>10;

      所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39的“数根”。

   

             通过运算可以发现任何一个数的“数根”都是一个取值范围在 1 ~ 9之间的正整数,

    且任何一个正整数都只有唯一的一个“数根”与其相对应。

             题目要求数字 n^n 的“数根”

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char a[1010];
    int i,j,s,l;
    while(~scanf("%s",&a)&&a[0]!='0')
    {
        l=strlen(a);
        s=0;
        for(i=0;i<l;i++)
        {
            s=s+a[i]-'0';
        }
        s=s%9;
        if(s==0)
            s=9;
        printf("%d\n",s);
    }
    return 0;
}




一个数对九取余,得到的数称之为九余数;

一个数的九余数等于它的各个数位上的数之和的九余数!


目录
相关文章
UVa10484 - Divisibility of Factors(数论)
UVa10484 - Divisibility of Factors(数论)
58 1
|
机器学习/深度学习
51nod 1225 余数之和 (数论)整除分块
51nod 1225 余数之和 (数论)整除分块
59 0
|
Windows
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
80 0
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
欧拉计划Problem 5 最小公倍数
欧拉计划Problem 5 最小公倍数
[Codeforces] 1557 C Moamen and XOR(组合数学)
题意: 用 < 2k的数填充到长度为n的数组中,要使得数组中所有数& >= ^,问方案数 显然,当k == 1的时候,答案为1,只有当所有的数全为1的情况才可以满足题意 对于其他的情况{ 用小于2k的数进行填充,那么说明填充的数字的二进制位数最多可以有k kk位, 从数的个数的角度来说,奇数个1^ 之后的结果是1,偶数个1^ 之后的结果是0,而对于0来讲,不管多少个0,^起来结果都是0 只要有一个0,那么说这一位上&之后就是0,而为了让^为0,那么只能够选择偶数个1 如果某一位上&为1,那么^为1的情况需要讨论n的奇偶性
114 0
|
机器学习/深度学习
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
103 0
|
Java
HDOJ 1753 大明A+B(大数~)
HDOJ 1753 大明A+B(大数~)
106 0
|
Java
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
97 0
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
101 0
|
人工智能 Python
codeforces1151B Dima(异或的性质)
codeforces1151B题解(异或的性质)
1351 0