poj 1027 The 3n + 1 problem(模拟,水题)

简介:
The 3n + 1 problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43840   Accepted: 13797

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
Consider the following algorithm: 


1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then n <-- 3n+1

5. else n <-- n/2

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

注意:

(1)i和j的大小需要判断,但是输出时要和输入时一致。

(2)这里用的是暴力,一开始只是尝试的态度,本以为会超时的,没想到过了。

复制代码
#include <stdio.h>
#define GET_MAX(a,b) a>b?a:b
#define GET_MIN(a,b) a<b?a:b

int get_cycle_length(int num)
{
    int count = 1;
    while(num!=1)
    {
        if(num%2==0)
        num /= 2;
        else num = 3*num+1;
        count++;
    }
    return count;
}

int main()
{
    int begin,end;
    int i,j,k,length,max,index;
    while(scanf("%d%d",&i,&j)!=EOF)
    {
        max = -1;
        begin = GET_MIN(i,j);
        end = GET_MAX(i,j);
        for(k = begin; k<= end;k++)
        {
            length = get_cycle_length(k);
            if(length>max)
            {
                max = length;
                index = k;
            }
        }
        printf("%d %d %d\n",i,j,max);
    }
    return 0;
}
复制代码











本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/10/03/2710915.html  ,如需转载请自行联系原作者

相关文章
|
3月前
【洛谷 P1219】[USACO1.5]八皇后 Checker Challenge 题解(深度优先搜索+回溯法)
**USACO1.5八皇后挑战**是关于在$n\times n$棋盘上放置棋子的,确保每行、每列及两条主对角线上各有一个且仅有一个棋子。给定$6$作为输入,输出前$3$个解及解的总数。例如,对于$6\times6$棋盘,正确输出应包括解的序列和总数。代码使用DFS解决,通过跟踪对角线占用状态避免冲突。当找到所有解时,显示前三个并计数。样例输入$6$产生输出为解的前三个排列和总数$4$。
29 0
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
|
定位技术
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
126 0
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
算法 C++
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
107 0
HDOJ/HDU 2551 竹青遍野(打表~)
HDOJ/HDU 2551 竹青遍野(打表~)
104 0
HDOJ(HDU) 1465 不容易系列之一(错排)
HDOJ(HDU) 1465 不容易系列之一(错排)
82 0