POJ-2492,A Bug's Life(分类并查集)

简介: POJ-2492,A Bug's Life(分类并查集)

Description:


Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.


Input:


The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.


Output:



The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.


Sample Input:


2


3 3


1 2


2 3


1 3


4 2


1 2


3 4


Sample Output:


Scenario #1:


Suspicious bugs found!


Scenario #2:


No suspicious bugs found!


程序代码:


#include<iostream>
#include<cstdio>
using namespace std;
#define N 2000000
int f[N+1];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
  return ;
}
int main()
{
  int t,n,m,a,b,ans=1;
  scanf("%d",&t);
  while(t--)
  {
    int flag=0;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=N;i++)
      f[i]=i;
    while(m--)
    {
      scanf("%d %d",&a,&b);
      if(flag==1)
        continue;
      if(getf(a)==getf(b)||getf(a+n)==getf(b+n))
      {//根节点一样,代表性别相同 
        flag=1;
        continue;
      }
      else
      {//合并 
        merge(a,b+n);
        merge(a+n,b);
      }
    }
    printf("Scenario #%d:\n",ans++);
    if(flag==1)
      printf("Suspicious bugs found!\n\n");
    else
      printf("No suspicious bugs found!\n\n");
  }
  return 0;
}

 


相关文章
|
7月前
【每日一题Day165】LC1039多边形三角剖分的最低得分 | 区间dp
【每日一题Day165】LC1039多边形三角剖分的最低得分 | 区间dp
59 0
|
算法 测试技术
每日一题:LeetCode-LCR 143.子结构判断
每日一题:LeetCode-LCR 143.子结构判断
|
人工智能
P1208 [USACO1.3]混合牛奶 Mixing Milk(贪心思想加一点特别的循环)
P1208 [USACO1.3]混合牛奶 Mixing Milk(贪心思想加一点特别的循环)
78 0
|
算法 Java
经典算法学习之---折半查找(三)
经典算法学习之---折半查找(三)
81 0
|
机器学习/深度学习 算法
经典算法学习之---折半查找(二)
经典算法学习之---折半查找(二)
381 0
|
存储 自然语言处理 算法
经典算法学习之---折半查找(一)
经典算法学习之---折半查找(一)
115 0
|
算法 C++ Python
【每日算法Day 85】图解算法:一行代码解决约瑟夫环的变体
【每日算法Day 85】图解算法:一行代码解决约瑟夫环的变体
114 0
线段树与树状数组总结分析(可能是最终版)(上)
线段树与树状数组总结分析(可能是最终版)
57 0
【每日一题Day63】LC1753移除石子的最大得分 | 贪心 + 数学
当对a,b,c进行升序排序后,如果a+b≥c,应先优先让a 和b去匹配,匹配的次数为a+b−c,得分为count=⌈(a+b−c)/2⌉
103 0
|
JSON 算法 前端开发
LeetCode --- 经典算法题之二分查找三回合
LeetCode --- 经典算法题之二分查找三回合
156 0
LeetCode --- 经典算法题之二分查找三回合

热门文章

最新文章