POJ-2492,A Bug's Life(分类并查集)

简介: POJ-2492,A Bug's Life(分类并查集)

Description:


Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.


Input:


The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.


Output:



The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.


Sample Input:


2


3 3


1 2


2 3


1 3


4 2


1 2


3 4


Sample Output:


Scenario #1:


Suspicious bugs found!


Scenario #2:


No suspicious bugs found!


程序代码:


#include<iostream>
#include<cstdio>
using namespace std;
#define N 2000000
int f[N+1];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
  return ;
}
int main()
{
  int t,n,m,a,b,ans=1;
  scanf("%d",&t);
  while(t--)
  {
    int flag=0;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=N;i++)
      f[i]=i;
    while(m--)
    {
      scanf("%d %d",&a,&b);
      if(flag==1)
        continue;
      if(getf(a)==getf(b)||getf(a+n)==getf(b+n))
      {//根节点一样,代表性别相同 
        flag=1;
        continue;
      }
      else
      {//合并 
        merge(a,b+n);
        merge(a+n,b);
      }
    }
    printf("Scenario #%d:\n",ans++);
    if(flag==1)
      printf("Suspicious bugs found!\n\n");
    else
      printf("No suspicious bugs found!\n\n");
  }
  return 0;
}

 


相关文章
|
4天前
【洛谷 P1219】[USACO1.5]八皇后 Checker Challenge 题解(深度优先搜索+回溯法)
**USACO1.5八皇后挑战**是关于在$n\times n$棋盘上放置棋子的,确保每行、每列及两条主对角线上各有一个且仅有一个棋子。给定$6$作为输入,输出前$3$个解及解的总数。例如,对于$6\times6$棋盘,正确输出应包括解的序列和总数。代码使用DFS解决,通过跟踪对角线占用状态避免冲突。当找到所有解时,显示前三个并计数。样例输入$6$产生输出为解的前三个排列和总数$4$。
10 0
|
定位技术
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
112 0
HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)
|
人工智能 BI
[UVA 1599] Ideal Path | 细节最短路
Description New labyrinth attraction is open in New Lostland amusement park. The labyrinth consists of n rooms connected by m passages. Each passage is colored into some color ci .
179 0
SDUT - 2498: 数据结构实验之图论十一:AOE网上的关键路径
SDUT - 2498: 数据结构实验之图论十一:AOE网上的关键路径
94 0
【1150】Travelling Salesman Problem (25分)【图论】
【1150】Travelling Salesman Problem (25分)【图论】 【1150】Travelling Salesman Problem (25分)【图论】
83 0