POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)

简介: POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)

单调栈是栈内元素保持一定单调性(单调递增或单调递减)的栈。这里的单调递增或递减是指的从栈顶栈底单调递增或递减, 需要注意的是它具有严格性(严格单调增或减)。

单调递增栈的实现:如果栈为空或入栈元素值小于栈顶元素值,则入栈;否则,如果入栈则会破坏栈的单调性,则需要把比入栈元素小的元素全部出栈。

单调递增栈模板

stack<int> s;
while (!s.empty() && t>=s.top())
    s.pop();
ans+=s.size();
s.push(t);

POJ 3250 Bad Hair Day 应用单调栈解题
转化成第i个牛可以被左边几个牛看见

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <algorithm>
using namespace std;
typedef long long ll;

int main()
{
   
    int n, t;
    scanf("%d", &n);
    stack<int> s;
    scanf("%d", &t);
    s.push(t);
    ll ans=0;
    for (int i=2; i<=n; i++){
   
        scanf("%d", &t);
        while (!s.empty() && t>=s.top())
            s.pop();
        ans+=s.size();
        s.push(t);
    }
    printf("%lld", ans);
    return 0;
}

POJ 2796 Feel Good
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.
Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.
Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5
主要思路:
找出每个点向左向右第一个比它小的位置l和r,那么在l+1和r-1的区间内
他就是最小的值,用一个前缀和的差来记录这个区间的和,最后求从1位置到n位置
最小值乘区间和的最大值即可

#include <iostream>
#include <cstdio>
#include <cmath> 
#include <cstring> 
#include <string>
#include <map> 
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;

typedef long long ll;
ll a[100005], sum[100005];

int main()
{
   
    int n, t=0;
    int left[100005], right[100005];
    while (scanf("%d", &n)!=EOF && n){
   
        //if (t++)    printf("\n");
        memset(a, 0, sizeof(a));
        memset(left, -1, sizeof(left));
        memset(right, -1, sizeof(right));
        memset(sum, 0, sizeof(sum));

        for (int i=1; i<=n; i++){
   
            scanf("%lld", &a[i]);
            sum[i]=sum[i-1]+a[i];
        }

        stack<int> s;
        //找每个结点右边第一个比它小的位置 
        for (int i=1; i<=n; i++){
   
            while (!s.empty() && a[s.top()]>a[i]){
   
                right[s.top()]=i;
                s.pop();
            }
            s.push(i);
        }

        while (!s.empty())    s.pop();
        //找每个结点左边第一个比它小的位置 
        for (int i=n; i>=1; i--){
   
            while (!s.empty() && a[s.top()]>a[i]){
   
                left[s.top()]=i;
                s.pop();
            }
            s.push(i);
        }

        ll ans=-1;
        int ans_l=-1, ans_r=-1;
        for (int i=1; i<=n; i++){
   
            int l=(left[i]==-1? 0: left[i]);
            int r=(right[i]==-1? n: right[i]-1);
            ll cur=(sum[r]-sum[l])*a[i];
            if (cur>ans){
   
                ans=cur;
                ans_l=l+1;
                ans_r=r;
            }
        }
        printf("%lld\n%d %d\n", ans, ans_l, ans_r);
    }
    return 0;
}

参考链接:
https://blog.csdn.net/Floraqiu/article/details/81947461
https://blog.csdn.net/flx413/article/details/80188776

相关文章
|
23小时前
|
算法 安全 NoSQL
2024重生之回溯数据结构与算法系列学习之栈和队列精题汇总(10)【无论是王道考研人还是IKUN都能包会的;不然别给我家鸽鸽丢脸好嘛?】
数据结构王道第3章之IKUN和I原达人之数据结构与算法系列学习栈与队列精题详解、数据结构、C++、排序算法、java、动态规划你个小黑子;这都学不会;能不能不要给我家鸽鸽丢脸啊~除了会黑我家鸽鸽还会干嘛?!!!
|
19天前
初步认识栈和队列
初步认识栈和队列
47 10
|
14天前
数据结构(栈与列队)
数据结构(栈与列队)
15 1
|
18天前
|
存储 JavaScript 前端开发
为什么基础数据类型存放在栈中,而引用数据类型存放在堆中?
为什么基础数据类型存放在栈中,而引用数据类型存放在堆中?
54 1
|
15天前
【数据结构】-- 栈和队列
【数据结构】-- 栈和队列
12 0
|
19天前
探索顺序结构:栈的实现方式
探索顺序结构:栈的实现方式
|
19天前
|
存储 C语言
栈和队列题目练习
栈和队列题目练习
13 0
|
27天前
|
存储 算法 搜索推荐
探索常见数据结构:数组、链表、栈、队列、树和图
探索常见数据结构:数组、链表、栈、队列、树和图
84 64
|
20天前
|
算法 程序员 索引
数据结构与算法学习七:栈、数组模拟栈、单链表模拟栈、栈应用实例 实现 综合计算器
栈的基本概念、应用场景以及如何使用数组和单链表模拟栈,并展示了如何利用栈和中缀表达式实现一个综合计算器。
18 1
数据结构与算法学习七:栈、数组模拟栈、单链表模拟栈、栈应用实例 实现 综合计算器
|
2月前
|
算法 安全 测试技术
golang 栈数据结构的实现和应用
本文详细介绍了“栈”这一数据结构的特点,并用Golang实现栈。栈是一种FILO(First In Last Out,即先进后出或后进先出)的数据结构。文章展示了如何用slice和链表来实现栈,并通过golang benchmark测试了二者的性能差异。此外,还提供了几个使用栈结构解决的实际算法问题示例,如有效的括号匹配等。
golang 栈数据结构的实现和应用