HDU-1032,The 3n + 1 problem(水题)

简介: HDU-1032,The 3n + 1 problem(水题)

Problem Description:


Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.


Consider the following algorithm:



   1.      input n


   2.      print n


   3.      if n = 1 then STOP


   4.           if n is odd then n <- 3n + 1


   5.           else n <- n / 2


   6.      GOTO 2



Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1


It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)


Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.


For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.  


Input:


The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.


You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.


You can assume that no opperation overflows a 32-bit integer.


Output:


For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).  


Sample Input:


1 10


100 200


201 210


900 1000


Sample Output:


1 10 20


100 200 125


201 210 89


900 1000 174


解题思路:


这道题就是说,给你一个范围区间内的所有数,对这里的每个数进行变换,如果是奇数,就变成3n+1;如果是偶数,就变成自身的一半,直到这个数变成1为止,记录中间经历了多少次。要求我们算出区间内每个数经历这样变换的次数,并输出最多的次数。(有一点小坑:一定要保证区间从小到大,如果a>b,要先交换位置,使得a<b即可)


程序代码:


#include<bits/stdc++.h>
using namespace std;
int main()
{
  int a,b,t;
  while(cin>>a>>b)
  {
    cout<<a<<" "<<b<<" ";
    if(a>b)
    {
      t=a;
      a=b;
      b=t;
    }
    int max=0;
    for(int i=a;i<=b;i++)
    {
      int n=i,sum=1;
      while(n!=1)
      {
        if(n&1)//等价于n%2==1 
          n=3*n+1;
        else
          n=n/2;
        sum++;
      }
      if(sum>max)
        max=sum;
    }
    cout<<max<<endl;
  }
  return 0;
}


相关文章
UVa1531 - Problem Bee
UVa1531 - Problem Bee
59 0
Leetcode 365. Water and Jug Problem
一句话理解题意:有容积为x和y升的俩水壶,能不能量出z升的水。 我刚开始看到这题,立马就想了下暴力搜索的可能性,但考虑了下数据大小,立马放弃这个暴力的想法,于是意识到肯定有比较简单的数学方法,其实我自己没想到,后来看还是看了别人的代码,很多博客都直接给出了解法, 但没介绍为什么能这么解。所以我决定解释下我自己的思路。
59 0
LeetCode 365. Water and Jug Problem
有两个容量分别为 x升 和 y升 的水壶以及无限多的水。请判断能否通过使用这两个水壶,从而可以得到恰好 z升 的水?
95 0
LeetCode 365. Water and Jug Problem
HDOJ(HDU) 1570 A C
HDOJ(HDU) 1570 A C
113 0
HDOJ(HDU) 1570 A C
HDU-1002,A + B Problem II(Java大数)
HDU-1002,A + B Problem II(Java大数)
|
物联网 Go C++
洛谷【2】P1001 A+B Problem
洛谷【2】P1001 A+B Problem
HDOJ/HDU 1372 Knight Moves(经典BFS)
HDOJ/HDU 1372 Knight Moves(经典BFS)
142 0
|
数据挖掘
HDOJ 1032(POJ 1207) The 3n + 1 problem
HDOJ 1032(POJ 1207) The 3n + 1 problem
136 0
HDOJ1002题A + B Problem II,2个大数相加
HDOJ1002题A + B Problem II,2个大数相加
125 0
|
Java 文件存储
HDOJ(HDU) 2132 An easy problem
HDOJ(HDU) 2132 An easy problem
123 0