HDU-1032,The 3n + 1 problem(水题)

简介: HDU-1032,The 3n + 1 problem(水题)

Problem Description:


Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.


Consider the following algorithm:



   1.      input n


   2.      print n


   3.      if n = 1 then STOP


   4.           if n is odd then n <- 3n + 1


   5.           else n <- n / 2


   6.      GOTO 2



Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1


It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)


Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.


For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.  


Input:


The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.


You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.


You can assume that no opperation overflows a 32-bit integer.


Output:


For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).  


Sample Input:


1 10


100 200


201 210


900 1000


Sample Output:


1 10 20


100 200 125


201 210 89


900 1000 174


解题思路:


这道题就是说,给你一个范围区间内的所有数,对这里的每个数进行变换,如果是奇数,就变成3n+1;如果是偶数,就变成自身的一半,直到这个数变成1为止,记录中间经历了多少次。要求我们算出区间内每个数经历这样变换的次数,并输出最多的次数。(有一点小坑:一定要保证区间从小到大,如果a>b,要先交换位置,使得a<b即可)


程序代码:


#include<bits/stdc++.h>
using namespace std;
int main()
{
  int a,b,t;
  while(cin>>a>>b)
  {
    cout<<a<<" "<<b<<" ";
    if(a>b)
    {
      t=a;
      a=b;
      b=t;
    }
    int max=0;
    for(int i=a;i<=b;i++)
    {
      int n=i,sum=1;
      while(n!=1)
      {
        if(n&1)//等价于n%2==1 
          n=3*n+1;
        else
          n=n/2;
        sum++;
      }
      if(sum>max)
        max=sum;
    }
    cout<<max<<endl;
  }
  return 0;
}


相关文章
|
9月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
物联网 Go C++
洛谷【2】P1001 A+B Problem
洛谷【2】P1001 A+B Problem
HDOJ/HDU 2560 Buildings(嗯~水题)
HDOJ/HDU 2560 Buildings(嗯~水题)
96 0
HDOJ/HDU 2560 Buildings(嗯~水题)
|
算法 C++
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
89 0
HDOJ(HDU) 2090 算菜价(简单水题、)
HDOJ(HDU) 2090 算菜价(简单水题、)
158 0
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
100 0
HDOJ(HDU) 1718 Rank(水题、、、)
HDOJ(HDU) 1718 Rank(水题、、、)
58 0