POJ-1005,I Think I Need a Houseboat(数学题)

简介: POJ-1005,I Think I Need a Houseboat(数学题)

Description:


Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.


After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)


Input:


The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.


Output:


For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”  


Sample Input:


2


1.0 1.0


25.0 0.0


Sample Output:


Property 1: This property will begin eroding in year 1.


Property 2: This property will begin eroding in year 20.


END OF OUTPUT.


解题思路:


这道题的大致意思就是说,以原点(0,0)开始,每年50平方英里的速度开始向外扩展,问经过多少年才能达到样例输入中点的坐标的位置,那么我们直接求出样例给出的坐标点对应的半圆的面积,然后除以50就可以了(注意题中说数据的第一年从1开始),所以我们最终求出的年数要加1才是正确的!!!


程序代码:  


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
const double PI=3.1415926;
int main()
{
  int t,ans=0;
  double x,y;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%lf %lf",&x,&y);
    int year=0;
    year=(PI*(x*x+y*y)/2)/50+1;
    printf("Property %d: This property will begin eroding in year %d.\n",++ans,year);
  }
  printf("END OF OUTPUT.\n");
  return 0;
}


相关文章
|
移动开发 Shell
蓝桥杯:2020 国赛 例题:天干地支
蓝桥杯:2020 国赛 例题:天干地支
84 0
|
8月前
|
C语言
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-4 报数 (20分)
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-4 报数 (20分)
|
8月前
|
测试技术
题目1444:蓝桥杯2014年第五届真题斐波那契
题目1444:蓝桥杯2014年第五届真题斐波那契
60 0
蓝桥杯系列5——填空题练习
蓝桥杯系列5——填空题练习
67 0
|
机器学习/深度学习
《蓝桥杯每日一题》背包dp·AcWing3382. 整数拆分
《蓝桥杯每日一题》背包dp·AcWing3382. 整数拆分
79 0
《蓝桥杯每日一题》递推·AcWing 3777. 砖块
《蓝桥杯每日一题》递推·AcWing 3777. 砖块
82 0
|
算法 C++
acwing蓝桥杯 - 数学知识【上】
acwing蓝桥杯 - 数学知识【上】
101 0
|
算法 决策智能
acwing蓝桥杯 - 数学知识【下】
acwing蓝桥杯 - 数学知识【下】
117 0
|
算法 测试技术 Python
第十二届蓝桥杯《杨辉三角》-二分法
第十二届蓝桥杯《杨辉三角》-二分法
103 0