AMH 4.2 PHP升级工具 2015.9.5-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

AMH 4.2 PHP升级工具 2015.9.5

西秦说云 2015-09-05 13:08:44 13092
amh4.2是我个人比较喜欢的一款Linux控制面板
不过由于作者开发5.X。免费版的4.2就停止开发了。目前一直使用的是php5.3.27
今天为大家提供一个PHP升级的工具,大家可以使用工具很方便的升级PHP版本
wget http://vpsug.aliapp.com/script/amhupgrade.sh
chmod a+x amhupgrade.sh
./amhupgrade.sh 2>&1 | tee php.log
界面如图

输入你要升级的版本,版本号可以从http://php.net/downloads.php获得
如升级到5.5.29


接下来是选择节点。
根据你的VPS。可以选择HK/US/JP/CN.这里使用CN


然后就会自动升级。
升级完成会自动重启amh
当你看到Done!!!就说明安装完了。可以到面板去看你的PHP版本了。
--------------------------------------------------------------
注意:PHP升级版本后原有拓展不能使用,如Pdo,mysqli,Zend等,需要手动编译。
--------------------------------------------------------------
有问题请在本帖回复。附上生成的php.log
Linux PHP
分享到
取消 提交回答
全部回答(6)
  • 门人木牙子
    2016-12-06 23:06:01
    ReAMH 4.2 PHP升级工具 2015.9.5
    amhupgrade.sh链接失效,请教如何升级?
    0 0
  • kkxt
    2016-08-14 00:52:23
    ReAMH 4.2 PHP升级工具 2015.9.5
    求编译教程西秦大大
    0 0
  • 鬼才神兵
    2015-09-17 08:33:51
    回 3楼(路过已错过) 的帖子
    http://bbs.aliyun.com/read/257825.html?spm=5176.7189909.0.0.wBQkqN
    组件安装请看这个帖子!
    0 0
  • 路过已错过
    2015-09-13 07:32:10
    回1楼西秦的帖子
    请问楼主升级后mysqli,Zend该如何编译呢?

    -------------------------

    ReAMH4.2PHP升级工具2015.9.5
    引用第1楼西秦于2015-09-05 13:10发表的  :
    更新日志2015.9.5 添加本帖地址。 [url=http://bbs.aliyun.com/job.php?action=topost&tid=256612&pid=700774][/url]

    请问版主,按照你说的进行升级到5.5.29后为什么后台显示的是5.3.18,使用php探针显示的也依然还是5.3.18而不是5.5.29呢?
    0 0
  • 妙正灰
    2015-09-05 13:26:48
    升级Nginx也很方便, 你也写一个咯!
    0 0
滑动查看更多

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程