hdu 3038 How Many Answers Are Wrong(并查集)

简介:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1210    Accepted Submission(s): 486


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

 

Output
A single line with a integer denotes how many answers are wrong.
 

 

Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
 

 

Sample Output
1
分析:
这道题目和hdu(3047)内容完全一样。。。。。只不过这里要注意找集合时,因为每次给提供的数据其实是在一个集合内,因此a--;这句话一定要弄明白。还有数据的范围改变了。。。上下的代码一点没动,提交通过
详细分析见 hdu 3074
 
复制代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXNUM 200005

using namespace std;
//father:存储的是节点的父节点的下标,
//dist存储的是节点到父节点的和
int father[MAXNUM],dist[MAXNUM];
int n,m;

int find_father(int a)
{
    if(father[a]==a)return a;
    int tem = father[a];
    father[a]=find_father(father[a]);
    dist[a] += dist[tem];
    return father[a];
}

void union_set(int a,int b,int x)
{
    int ra = find_father(a);
    int rb = find_father(b);
    father[rb]=ra;
    dist[rb]=dist[a]+x-dist[b];
}
int main()
{
    int a,b,ra,rb,x,conflics;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dist,0,sizeof(dist));
        for(int i=0;i<=n;i++)
        father[i]=i;
        conflics=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&x);
            a--;//注意这里,我在这里wrong了好几下
            ra = find_father(a);
            rb = find_father(b);
            if(ra==rb)
            {
                if(dist[b]-dist[a]!=x)conflics++;
            }
            if(ra!=rb)union_set(a,b,x);
        }
        printf("%d\n",conflics);
    }
    return 0;
}
复制代码

 







本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2012/10/31/2748622.html ,如需转载请自行联系原作者




相关文章
|
13天前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
|
7月前
|
开发框架 .NET
poj 3468 A Simple Problem with Integers线段树区间修改
题目意思很简单,有N个数,Q个操作, Q l r 表示查询从l到r 的和,C l r v 表示将从l到r 的值加上v,明显的线段树,不知道线段树的人肯定暴力,肯定超时,哈哈!!
19 0
|
9月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
100 0
|
C语言
HDOJ 1016 Prime Ring Problem素数环【深搜2】
HDOJ 1016 Prime Ring Problem素数环【深搜】
79 0
HDOJ 1016 Prime Ring Problem素数环【深搜】
HDOJ 1016 Prime Ring Problem素数环【深搜】
92 0
HDOJ 1016 Prime Ring Problem素数环【深搜】