KMP - HDU 1711 Number Sequence

简介: Number Sequence Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 11606    Accepted Submission...

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11606    Accepted Submission(s): 5294

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1 

 

Mean: 

 给你s1,s2两个串,让你找到s2在s1中出现的第一个位置。

analyse:

 KMP字符串水题.

Time complexity:O(n+m)

 

Source code:

#include<cstdio>
#include<cstring>
int l1 , l2;
int a [ 1000010 ],b [ 10010 ], Next [ 10010 ];

void getNext()
{
      Next [ 0 ] = 0;
      int i , k;
      for( i = 1 , k = 0; i < l2; ++ i)
      {
            while(b [ i ] !=b [ k ] && k > 0)
                  k = Next [ k - 1 ];
            if(b [ i ] ==b [ k ]) ++ k;
            Next [ i ] = k;
      }
}
int kmp()
{
      getNext();
      for( int i = 0 , k = 0; i < l1; ++ i)
      {
            while( a [ i ] !=b [ k ] && k > 0)
                  k = Next [ k - 1 ];
            if( a [ i ] ==b [ k ]) ++ k;
            if( k == l2) return i - l2 + 2;
      }
      return - 1;
}
int main()
{
      int t;
      scanf( "%d" , & t);
      while( t --)
      {
            scanf( "%d %d" , & l1 , & l2);
            for( int i = 0; i < l1; ++ i) scanf( "%d" , & a [ i ]);
            for( int i = 0; i < l2; ++ i) scanf( "%d" , &b [ i ]);
            printf( "%d \n " , kmp());
      }
      return 0;
}

 

目录
相关文章
|
存储 缓存 关系型数据库
Redo日志 (4)—log sequence number(六十二)
Redo日志 (4)—log sequence number(六十二)
|
Java C++
HDU-1005,Number Sequence(有规律的数学题)
HDU-1005,Number Sequence(有规律的数学题)
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem J. number sequence
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem J. number sequence
133 0
HDOJ(HDU) 2113 Secret Number(遍历数字位数的每个数字)
HDOJ(HDU) 2113 Secret Number(遍历数字位数的每个数字)
117 0
HDOJ(HDU) 1562 Guess the number(水题,枚举就行)
HDOJ(HDU) 1562 Guess the number(水题,枚举就行)
118 0
HDOJ 1005 Number Sequence
HDOJ 1005 Number Sequence
100 0
|
人工智能 Java Windows
枚举 + 进制转换 --- hdu 4937 Lucky Number
Lucky Number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 294    Accepted Submission(s):...
834 0
|
算法
Leetcode 313. Super Ugly Number
题目翻译成中文是『超级丑数』,啥叫丑数?丑数就是素因子只有2,3,5的数,7 14 21不是丑数,因为他们都有7这个素数。 这里的超级丑数只是对丑数的一个扩展,超级丑数的素因子不再仅限于2 3 5,而是由题目给定一个素数数组。与朴素丑数算法相比,只是将素因子变了而已,解法还是和朴素丑数一致的。
99 1

热门文章

最新文章