Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11606 Accepted Submission(s): 5294
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Mean:
给你s1,s2两个串,让你找到s2在s1中出现的第一个位置。
analyse:
KMP字符串水题.
Time complexity:O(n+m)
Source code:
#include<cstdio>
#include<cstring>
int l1 , l2;
int a [ 1000010 ],b [ 10010 ], Next [ 10010 ];
void getNext()
{
Next [ 0 ] = 0;
int i , k;
for( i = 1 , k = 0; i < l2; ++ i)
{
while(b [ i ] !=b [ k ] && k > 0)
k = Next [ k - 1 ];
if(b [ i ] ==b [ k ]) ++ k;
Next [ i ] = k;
}
}
int kmp()
{
getNext();
for( int i = 0 , k = 0; i < l1; ++ i)
{
while( a [ i ] !=b [ k ] && k > 0)
k = Next [ k - 1 ];
if( a [ i ] ==b [ k ]) ++ k;
if( k == l2) return i - l2 + 2;
}
return - 1;
}
int main()
{
int t;
scanf( "%d" , & t);
while( t --)
{
scanf( "%d %d" , & l1 , & l2);
for( int i = 0; i < l1; ++ i) scanf( "%d" , & a [ i ]);
for( int i = 0; i < l2; ++ i) scanf( "%d" , &b [ i ]);
printf( "%d \n " , kmp());
}
return 0;
}
#include<cstring>
int l1 , l2;
int a [ 1000010 ],b [ 10010 ], Next [ 10010 ];
void getNext()
{
Next [ 0 ] = 0;
int i , k;
for( i = 1 , k = 0; i < l2; ++ i)
{
while(b [ i ] !=b [ k ] && k > 0)
k = Next [ k - 1 ];
if(b [ i ] ==b [ k ]) ++ k;
Next [ i ] = k;
}
}
int kmp()
{
getNext();
for( int i = 0 , k = 0; i < l1; ++ i)
{
while( a [ i ] !=b [ k ] && k > 0)
k = Next [ k - 1 ];
if( a [ i ] ==b [ k ]) ++ k;
if( k == l2) return i - l2 + 2;
}
return - 1;
}
int main()
{
int t;
scanf( "%d" , & t);
while( t --)
{
scanf( "%d %d" , & l1 , & l2);
for( int i = 0; i < l1; ++ i) scanf( "%d" , & a [ i ]);
for( int i = 0; i < l2; ++ i) scanf( "%d" , &b [ i ]);
printf( "%d \n " , kmp());
}
return 0;
}