[导入]LAMP架构下安装Drupal-阿里云开发者社区

开发者社区> 文艺小青年> 正文

[导入]LAMP架构下安装Drupal

简介:
+关注继续查看
LAMP架构:
Linux + Apache + MySQL + PHP

用的是RedHat 7.2 Linux 操作系统。
由于该系统本身已经带有Apache,MySQL和PHP,因此尝试使用回原来的版本。
Apache-1.3.20-16;mysql-3.23.41-1;php-4.0.6-7
Linux系统安装时并没有自动安装mysql,因此需要手工安装第二张盘上的相应的RPM。
**注意RPM之间的顺序关系和关联关系,安装php-mysql-4.0.6-7。

下载安装Drupal4.2,但出现不可以访问页面的错误。
改为安装Drupal4.1,看起来正常,估计是安装Drupal4.2需要php4.1以上。

心得:
[b]
[color=blue]
版本之间的关系十分重要;
rpm的几个常用参数和命令:-ivh; -e ; -qa; -ql再配合grep一起使用;
tar的几个常用参数和命令:-zxvf *.gz 或者 *.tgz;
mysql装了高版本后要装低版本,必须将全部铲掉,连数据库;
.htaccess的作用;

mysql的用户权限管理 Insert ...   (浏览全文  引用此文)



本文转自风前絮~~博客园博客,原文链接:http://www.cnblogs.com/windsails/archive/2004/09/03/39337.html,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
每周问答精选:PolarDB for PostgreSQL 开源版和阿里云上的版本是同一版本吗?
为了方便各位小伙伴能够方便、快速的了解到 PolarDB 开源数据库的相关的使用问题,社区每周将精选群内高质量的问题通过该栏目予以统一答复,希望能够对大家有所帮助。
5 0
【Elastic Engineering】Elasticsearch:使用 _validate API 在不执行查询的情况下验证查询
Elasticsearch:使用 _validate API 在不执行查询的情况下验证查询
5 0
也谈分库分表在实际应用的实践(下)
也谈分库分表在实际应用的实践(下)
11 0
DevOps中开发的作用和主动性
DevOps中开发的作用和主动性
3 0
Spring Boot Serverless 实战系列 | 性能调优
Spring Boot Serverless 实战系列第四篇来啦,本文将向大家介绍如何对 Serverless 应用进行性能调优。
11 0
3576
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载