hdu 1258 Sum It Up

简介:

点击打开链接

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5241    Accepted Submission(s): 2733


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
 
 
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
 
 
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
题目大意:就是给你一个数 t 和数 n,然后有n个数,问 t 是否能用 n 个数中的某几个数相加组成,如果能,把所有的情况输出(从大到小)
解题思路:深度搜索dfs,还需要进行一下判重.
上代码:
/*
Date : 2015-09-07 晚上

Author : ITAK

Motto :

今日的我要超越昨日的我,明日的我要胜过今日的我;
以创作出更好的代码为目标,不断地超越自己。
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int t, n;
bool flag;
int a[20],b[20];
///比较(输出时需要用的)
int cmp(int a, int b)
{
    return a > b;
}
///深搜
void dfs(int posa, int sum, int posb)
{
    if(sum > t)
        return;
    if(sum == t)
    {
        flag = 1;
        for(int i=0; i<posb; i++)
        {
            if(i == 0)
                cout<<b[i];
            else
                cout<<"+"<<b[i];
        }
        cout<<endl;
    }
    for(int i=posa; i<n; i++)
    {
        b[posb] = a[i];
        dfs(i+1, sum+a[i], posb+1);
        while(i+1<n && a[i]==a[i+1])///判重
            i++;

    }
}
int main()
{
    while(~scanf("%d%d",&t,&n))
    {
        if(!t && !n)
            break;
        flag = 0;
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n,cmp);
        printf("Sums of %d:\n",t);
        dfs(0,0,0);
        if(!flag)
            puts("NONE");
    }
    return 0;
}


目录
相关文章
|
11月前
|
存储 算法 安全
LeetCode - #1 Two Sum
我们社区从本期开始会将顾毅(Netflix 增长黑客,《iOS 面试之道》作者,ACE 职业健身教练。)的 Swift 算法题题解整理为文字版以方便大家学习与阅读。 不积跬步,无以至千里;不积小流,无以成江海,Swift社区 伴你前行。
LeetCode - #1 Two Sum
|
12月前
|
机器学习/深度学习
leetcode - two-sum
leetcode - two-sum
64 0
POJ 1844 Sum
POJ 1844 Sum
82 0
|
机器学习/深度学习 Android开发 C++
LeetCode之Two Sum
LeetCode之Two Sum
98 0
|
算法 索引 C++
|
存储 人工智能 算法
HDU 1024 Max Sum Plus Plus【动态规划求最大M子段和详解 】
Max Sum Plus Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29942    Accepted Submissio...
2363 0