【漏洞公告】CVE-2017-7529:Nginx敏感信息泄露-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

【漏洞公告】CVE-2017-7529:Nginx敏感信息泄露

正禾 2017-07-12 10:59:24 17827
2017年7月11日,Nginx官方 发布最新的安全公告,漏洞CVE编号为CVE-2017-7529,该 在nginx范围过滤器中发现了一个安全问题,通过精心 构造的恶意请求可能会导致整数溢出并且不正确处理范围,从而导致敏感信息 泄漏, 存在安全风险
具体详情如下:                                                                                                                
漏洞编号:
CVE-2017-7529
漏洞名称:
Nginx敏感信息泄露
官方评级:
中危
漏洞描述:
当使用nginx标准模块时,这允许攻击者如果从缓存返回响应,则获取缓存文件头,黑客可以通过缓存文件头获取包含IP地址的后端服务器或其他敏感信息,从而导致信息泄露。
漏洞利用条件和方式:
远程利用
漏洞影响范围:
Nginx 0.5.6 - 1.13.2.
漏洞检测:
自查使用的Nginx版本是否在受影响范围内
漏洞修复建议(或缓解措施):
  • 在不影响业务的前提下,建议禁用multipart range功能,可以在Nginx配置文件中添加max_ranges 1;
server {
listen 80;
server_name localhost;
max_ranges 1; ----禁用multipart range分片功能

location / {
root /var/www/example.com;
index index.php;
}

location ~ \.php {
set $script $uri;
set $path_info "";

if ($uri ~ "^(.+\.php)(/.*)") {
set $script $1;
set $path_info $2;
}

client_body_temp_path /tmp 1;
client_max_body_size 2048m;
fastcgi_pass 127.0.0.1:9000;
fastcgi_read_timeout 300;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /var/www/example.com$script;

include /etc/nginx/fastcgi_params;
}
}


  • 建议升级到Nginx1.13.3, 1.12.1
  • 阿里云云盾WAF支持防御,可以选用WAF 防护。
情报来源:


















缓存 安全 应用服务中间件 PHP nginx
分享到
取消 提交回答
全部回答(4)
  • svenll
    2017-07-13 17:15:21
    Re【漏洞公告】CVE-2017-7529Nginx敏感信息泄露
    Integer overflow in the range filter
    Severity: medium
    Advisory
    CVE-2017-7529
    Not vulnerable: 1.13.3+, 1.12.1+
    Vulnerable: 0.5.6-1.13.2
    The patch  pgp

    官方是中级别啊
    0 0
  • 正禾
    2017-07-12 18:13:50
    回 2楼(冬) 的帖子
    升级Nginx到最新版本

    -------------------------

    回 4楼(svenll) 的帖子
    是的,昨天通过漏洞技术分析,确认风险不高
    0 0
  • 2017-07-12 16:05:27
    Re【漏洞公告】CVE-2017-7529Nginx敏感信息泄露
    这个大洞是怎么修复的
    0 0
  • mytsing520
    2017-07-12 11:43:59
    这个是个大洞,正在修复,感谢
    0 0
添加回答
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程