开发者社区> 问答> 正文

【漏洞公告】CVE-2017-15707:Apache S2-054 DoS漏洞

正禾 2017-12-01 17:34:04 15772
2017年12月01日,Apache官方公告S2-054漏洞,CVE编号为CVE-2017-15707,用户 在使用Struts REST插件时,如果使用默认的、过时的json-lib,则 攻击者可以使用精心制作的JSON请求,实施DoS攻击。

具体详情如下:


漏洞编号:
CVE-2017-15707
漏洞名称:
Apache S2-054 DoS漏洞
官方评级:
中危
漏洞描述:
在Struts REST插件中使用过时的json-lib时,可能会发生DoS攻击。
漏洞利用条件和方式:
通过PoC直接远程利用。
PoC状态:
未公开
漏洞影响范围:
Struts 2.5 - Struts 2.5.14
漏洞检测:
开发人员检查是否使用了受影响版本范围内的Struts软件。
漏洞修复建议(或缓解措施):
  • 升级到 Struts 2.5.14.1。

情报来源:
  • https://cwiki.apache.org/confluence/display/WW/S2-054











JSON 安全 Java Apache 网络架构 数据格式
分享到
取消 提交回答
全部回答(0)

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题