hdu 1712 ACboy needs your help

简介: ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。

ACboy needs your help

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 158   Accepted Submission(s) : 74


Problem Description


ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?


Input


The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.


Output


For each data set, your program should output a line which contains the number of the max profit ACboy will gain.


Sample Input

 


  2 2

1 2

1 3

2 2

2 1

2 1

2 3

3 2 1

3 2 1

0 0


 


Sample Output

 


  3

4

6


 

Source

HDU 2007-Spring Programming Contest


题意:ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。


思路:分组背包,注意同一门课程之能选1次。


#include<stdio.h>
#include<string.h>
int wi[155][155];   //作用值
int vi[155][155];   //所花天数
int xx[111];
int n,m;
int f[3333];
int package()   //背包模版
{
    for(int i=0;i<=m;i++)
        f[i]=0;
    for(int j=0;j<n;j++)
    {
        for(int h=m;h>=0;h--)
        {
            for(int i=0;i<m;i++)
            {
                if(h-vi[j][i]>=0)
                    f[h]=f[h]>f[h-vi[j][i]]+wi[j][i]?f[h]:f[h-vi[j][i]]+wi[j][i];
            }
        }
    }
    return f[m];
}
int main()
{
    int i,j;
    int ans;
    while(scanf("%d%d",&n,&m)&&m&&n)
    {
        memset(vi,0,sizeof(vi));
        memset(wi,0,sizeof(wi));
        for(i=0;i<n;i++)
        {    
            for(j=0;j<m;j++)
            {
                vi[i][j]=j+1;
                scanf("%d",&wi[i][j]);
            }
        }
        ans=package();
        printf("%d\n",ans);
    }
    return 0;
}


 

相关文章
|
6月前
|
Java
HDU-4552-怪盗基德的挑战书
HDU-4552-怪盗基德的挑战书
38 0
|
6月前
HDU-2089-不要62
HDU-2089-不要62
32 0
|
6月前
|
机器学习/深度学习 存储 人工智能
HDU - 5912——Fraction
HDU - 5912——Fraction
|
Java 测试技术
hdu 1228 A + B
hdu 1228 A + B
46 0
|
人工智能 Java
2021杭电多校5-Arrary-hdu7020
Array Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 965 Accepted Submission(s): 312 Problem Description Given an integer array a[1…n].
178 0
2021杭电多校5-Arrary-hdu7020