hdu 1712 ACboy needs your help

简介: ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。

ACboy needs your help

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 158   Accepted Submission(s) : 74


Problem Description


ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?


Input


The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.


Output


For each data set, your program should output a line which contains the number of the max profit ACboy will gain.


Sample Input

 


  2 2

1 2

1 3

2 2

2 1

2 1

2 3

3 2 1

3 2 1

0 0


 


Sample Output

 


  3

4

6


 

Source

HDU 2007-Spring Programming Contest


题意:ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。


思路:分组背包,注意同一门课程之能选1次。


#include<stdio.h>
#include<string.h>
int wi[155][155];   //作用值
int vi[155][155];   //所花天数
int xx[111];
int n,m;
int f[3333];
int package()   //背包模版
{
    for(int i=0;i<=m;i++)
        f[i]=0;
    for(int j=0;j<n;j++)
    {
        for(int h=m;h>=0;h--)
        {
            for(int i=0;i<m;i++)
            {
                if(h-vi[j][i]>=0)
                    f[h]=f[h]>f[h-vi[j][i]]+wi[j][i]?f[h]:f[h-vi[j][i]]+wi[j][i];
            }
        }
    }
    return f[m];
}
int main()
{
    int i,j;
    int ans;
    while(scanf("%d%d",&n,&m)&&m&&n)
    {
        memset(vi,0,sizeof(vi));
        memset(wi,0,sizeof(wi));
        for(i=0;i<n;i++)
        {    
            for(j=0;j<m;j++)
            {
                vi[i][j]=j+1;
                scanf("%d",&wi[i][j]);
            }
        }
        ans=package();
        printf("%d\n",ans);
    }
    return 0;
}


 

相关文章
|
机器学习/深度学习 人工智能
|
Java
HDU 1846(巴什博弈)
Brave Game Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4050    Accepted Submission(s): 2644 Problem Description 十年前读大学的时候,中国每年都要从国外引进一些电影大片,其中有一部电影就叫《勇敢者的游戏》(英文名称:Zathura),一直到现在,我依然对于电影中的部分电脑特技印象深刻。
798 0
|
存储
hdu 2795 Billboard
点击打开hdu 2795 思路: 线段树+单点更新 分析: 1 题目的意思是给定一个h*w的广告牌h为高,w为宽,现在有n个高为1宽为wi的小广告要放上去,原则是最先放最上面和最左边的位置 2 题目的h和w的最大值为10^9,但是n最大为200000。
773 0
hdu 4463 Outlets
点击打开链接hdu 4463 思路:最小生成树+kruskal 分析: 1 题目要求的找到n个商店组成n-1条边,并且要求耐克和苹果商店肯定要相连,求最短长度 2 很明显的最小生成树的模板题,由于要求耐克和苹果的商店要在一起那么就要把这两个商店编号合并到同一个集合,然后在利用kruskal计算。
914 0

热门文章

最新文章