Hdu 5585 Numbers

简介:

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 217    Accepted Submission(s): 151


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
 
 
2 3 5 7
 

Sample Output
 
 
YES YES YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5589  5588  5584  5583  5582 
 
题目大意:
给一个数N,如果N是2、3或者5的倍数,输出"YES",否则输出"NO".
解体思路:
注意数据范围,用字符串来做。。。比较水
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 1e5+5;
const int mod = 1e4+7;
const double eps = 1e-10;
const int INF = 0x3f3f3f3f;
LL gcd(LL a, LL b)
{
    if(b == 0)
        return a;
    return gcd(b, a%b);
}
char str[maxn];
int main()
{
    while(cin>>str)
    {
        int len = strlen(str);
        LL sum = 0;
        for(int i=0; i<len; i++)
            sum += str[i]-'0';
        if(sum%3==0 || (str[len-1]-'0')%2==0 || str[len-1]-'0'==5)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}


目录
相关文章
|
6月前
|
机器学习/深度学习 存储 人工智能
HDU - 5912——Fraction
HDU - 5912——Fraction
|
人工智能 Java
2021杭电多校5-Arrary-hdu7020
Array Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 965 Accepted Submission(s): 312 Problem Description Given an integer array a[1…n].
178 0
2021杭电多校5-Arrary-hdu7020
|
人工智能 Java
hdu 1712 ACboy needs your help
ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。
137 0
hdu 2087 剪花布条
点击打开链接hdu2087 思路:kmp 分析: 1 题目要求的是给定一个文本串和给定一个模式串,求文本串中有几个模式串。 2 注意文本串为"aaaaaa",模式串"aa"的时候,ans = 3 而不是5。
951 0
hdu 1298 T9
点击打开链接hdu 1298 题意:题目说的是在那遥远的星球有一款叫诺基亚的手机,键盘采用题目的图的样式。给定n个单词的出现的概率,规定是相加的比如hell出现为4,hello概率为3则hell的概率为7。
754 0
|
算法 BI 人工智能
hdu 1217 Arbitrage
点击打开链接hdu 1217 思路:最短路变形题(floyd 或 SPFA) 分析: 2 题目要求的是经过一轮的转换之后,原来的比例能够大于1。
900 0