开发者社区> hiekay> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

mac 安装tensorflow

简介: mac 安装tensorflow
+关注继续查看

必备: Python

要安装 TensorFlow,你的系统必须依据安装了以下任一 Python 版本:

  • Python 2.7
  • Python 3.3+

如果你的系统还没有安装符合以上版本的 Python,现在安装。

安装 Python,你可能需要禁用系统完整性保护(SIP)来获得从 Mac App Store 外安装软件的许可。

必备: pip

Pip安装和管理 Python写的软件包,如果你要使用本地 pip 安装,系统上必须安装下面的任一 pip 版本:

  • pip, for Python 2.7
  • pip3, for Python 3.n.

pip 或者 pip3 可能在你安装 Python 的时候已经安装了,执行以下任一命令确认系统上是否安装了 pip 或 pip3:

$ pip -V  # for Python 2.7
$ pip3 -V # for Python 3.n 

我们强烈建议使用 pip 或者 pip3 为 8.1 或者更新的版本安装 TensorFlow,如果没有安装,执行以下任一命令安装或更新:

$ sudo easy_install --upgrade pip
$ sudo easy_install --upgrade six

安装 TensorFlow

假设你的 Mac 上已经装好了必备的程序,按照以下步骤执行:

1.执行以下任一命令安装 TensorFlow:

$ pip install tensorflow      # Python 2.7; CPU support
 $ pip3 install tensorflow     # Python 3.n; CPU support

如果上面的命令执行完成,现在可以验证你的安装了。

2.(可选的) 如果步骤 1 失败了,执行下面的命令安装最新版本 TensorFlow:

$ sudo pip  install --upgrade tfBinaryURL   # Python 2.7
 $ sudo pip3 install --upgrade tfBinaryURL   # Python 3.n 

*推荐使用清华镜像

pip3 install tensorflow==2.0.0 -i https://pypi.tuna.tsinghua.edu.cn/simple  --default-timeout=1000

tfBinaryURL 是 Tensorflow 包的 URL,准确的 tfBinaryURL 值因操作系统和 Python 版本而异,在这里找到和你系统相关的 tfBinaryURL 值。例如,你要在 Mac OS X 上安装 Python 2.7 对应的 Tensorflow 版本,在虚拟环境中安装 Tensorflow 就执行下面的命令:

$ sudo pip3 install --upgrade \
 https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.2.1-py2-none-any.whl
```
 下一步
安装完成后,验证你的安装是否工作正常。
输入 pip3 list 查看 tensorflow 
``` 
pip3 list
``` 
![image.png](https://upload-images.jianshu.io/upload_images/5110710-f2ddf78ef293d3da.png?imageMogr2/auto-orient/strip%7CimageView2/2/w/1240)

卸载 TensorFlow
如果要卸载 TensorFlow,执行下面的命令:
``` 
$ pip uninstall tensorflow
$ pip3 uninstall tensorflow

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
mac 系统安装总结
引用:http://forum.ubuntu.org.cn/viewtopic.php?t=314304 要装64位的guest系统,需要:1.你的CPU是64位的2.你真机上装的host系统必须是64位的3.你安装的vmware/Vbox必须是64位的4.你在vmware/vbox中,创建虚拟机时,必须选择创建的是64位的虚拟机然后你的guest系统才能装64位的。
661 0
mac下使用brew安装node.js环境
mac下使用brew安装node.js环境
26 0
Mac下使用pecl安装PHP的swoole扩展实践
我记得之前用brew安装的PHP,再使用pecl很方便就可以安装swoole,于是我把自带的PHP卸载然后重新使用brew安装,并且安装了pecl,在通过pecl安装了swoole扩展,把这个安装过程记录下来,方便下次使用吧
192 0
mac电脑上安装appium报错:Failed at the appium-chromedriver@4.25.1 postinstall script.
mac电脑安装appium,装好node.js后,使用命令:npm install appium@1.18.0,安装appium,报如下错误
106 0
Mac 环境下 RabbitMQ 的安装
几个月之前,手上的一个项目开始使用 RabbitMQ,没错,就是跟兔子跑得一样快的一个消息队列。 之前并没有做系统的学习,只是了解一些简单用法,网上找一些例子,加上自己的加工,基本也可以满足常规的使用需求。
68 0
Mac安装vue.js开发环境
本来以为在Mac上搭建vue.js的环境挺简单的,谁知遇到各种问题(可能是RP问题),网上解决的方法也寥寥无几,这里就记录下遇到的坑。
296 0
【开发环境】Mac 安装 PyCharm 开发环境 ( 下载 PyCharm | 安装 PyCharm )
【开发环境】Mac 安装 PyCharm 开发环境 ( 下载 PyCharm | 安装 PyCharm )
71 0
【开发环境】Mac 中安装 Python3 最新版本 ( 下载 Python 最新版本 | 安装 Python3 | 验证 Python3 )(二)
【开发环境】Mac 中安装 Python3 最新版本 ( 下载 Python 最新版本 | 安装 Python3 | 验证 Python3 )(二)
44 0
【开发环境】Mac 中安装 Python3 最新版本 ( 下载 Python 最新版本 | 安装 Python3 | 验证 Python3 )(一)
【开发环境】Mac 中安装 Python3 最新版本 ( 下载 Python 最新版本 | 安装 Python3 | 验证 Python3 )(一)
79 0
【开发环境】Mac 中 IntelliJ IDEA 运行 Python 程序 ( 安装 Python Community Edition 插件 )
【开发环境】Mac 中 IntelliJ IDEA 运行 Python 程序 ( 安装 Python Community Edition 插件 )
182 0
+关注
hiekay
java 数据分析 数据可视化 大数据
183
文章
90
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载