poj 1504 Adding Reversed Numbers(数学水题)

简介:
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12526   Accepted: 6914

Description

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play. 

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros. 

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.

Output

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Sample Input

3
24 1
4358 754
305 794

Sample Output

34
1998
1


分析:
(1)一开始一直以为这个整数可能会是很大很大的一个数,用整型或是长整型都会长度不够。所以就计划有字符数组模拟,水平太差,模拟时一直出错。一怒之下直接用long long试了一下居然过了,只能说明标程里的测试数据不够严谨让我钻了个空子
(2)题意分析:就是把连个整数翻转过来,相加然后再翻转过去输出。

Source

复制代码
#include <stdio.h>

long long get_reverse(long long num)
{
    long long result = 0;
    while(num>0)
    {
        result = result*10 + num%10;
        num = num/10;
    }
    return result;
}

int main()
{
    long long num1,num2;
    int N;
    scanf("%d",&N);
    while(N--)
    {
        scanf("%lld%lld",&num1,&num2);
        num1 = get_reverse(num1);
        num2 = get_reverse(num2);
        num1 += num2;
        num1 = get_reverse(num1);
        printf("%lld\n",num1);
    }
    return 0;
}
复制代码






本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/10/04/2711577.html  ,如需转载请自行联系原作者





相关文章
|
9月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
AtCoder Beginner Contest 216 G - 01Sequence (并查集 贪心 树状数组 差分约束)
AtCoder Beginner Contest 216 G - 01Sequence (并查集 贪心 树状数组 差分约束)
103 0
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1370,Biorhythms(中国剩余定理)
本题主要就是应用中国剩余定理。
HDOJ/HDU 1256 画8(绞下思维~水题)
HDOJ/HDU 1256 画8(绞下思维~水题)
87 0
|
人工智能 BI 机器学习/深度学习