HDOJ/HDU 2560 Buildings(嗯~水题)

简介: HDOJ/HDU 2560 Buildings(嗯~水题)

Problem Description

We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

image.png



Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.


Output

Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.


Sample Input

2

2 2

1 1

0 0

3 3

1 0 1

0 0 1

1 1 0


Sample Output

2

5


水题一个~~

就是一个学校n*m的面积,然后有建筑~

1代表建筑,统计建筑的总数~

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int n =sc.nextInt();
            int m =sc.nextInt();
            int sum=0;
            for(int i=0;i<n;i++){
                for(int j=0;j<m;j++){
                    int a =sc.nextInt();
                    if(a==1){
                        sum++;
                    }
                }
            }
            System.out.println(sum);
        }
    }
}


目录
相关文章
HDOJ 1056 HangOver(水题)
HDOJ 1056 HangOver(水题)
100 0
HDOJ 1056 HangOver(水题)
HDOJ(HDU) 1570 A C
HDOJ(HDU) 1570 A C
100 0
HDOJ(HDU) 1570 A C
HDOJ(HDU) 2090 算菜价(简单水题、)
HDOJ(HDU) 2090 算菜价(简单水题、)
180 0
HDOJ/HDU 2551 竹青遍野(打表~)
HDOJ/HDU 2551 竹青遍野(打表~)
107 0
|
算法
HDOJ/HDU 1015 Safecracker(深搜)
HDOJ/HDU 1015 Safecracker(深搜)
98 0
HDOJ(HDU) 2503 a/b + c/d(最大公约数问题)
HDOJ(HDU) 2503 a/b + c/d(最大公约数问题)
131 0
HDOJ/HDU 2568 前进(简单题)
HDOJ/HDU 2568 前进(简单题)
123 0
HDOJ(HDU) 1406 完数
HDOJ(HDU) 1406 完数
105 0
HDOJ/HDU 1256 画8(绞下思维~水题)
HDOJ/HDU 1256 画8(绞下思维~水题)
123 0
HDOJ(HDU) 2161 Primes(素数打表)
HDOJ(HDU) 2161 Primes(素数打表)
111 0