Junos路由器静态路由及动态路由rip和ospf配置测试

简介:

一.测试拓扑:

wKioL1Ls1K-SwH1YAABW4dzX3A4810.jpg
二.基本配置:
A.R1:
interface Ethernet0/0
ip address 202.100.100.1 255.255.255.0
    no shut
interface Loopback0
    ip address 1.1.1.1 255.255.255.255
B.R2:
interface Ethernet0/0
    ip address 202.100.100.2 255.255.255.0
    no shut
interface Ethernet0/1
    ip address 202.100.1.2 255.255.255.0
    no shut
interface Loopback0
    ip address 2.2.2.2 255.255.255.255
C. JUNOS1:
set system root-authentication plain-text-password

set interfaces em0 unit 0 family inet address 202.100.1.10/24
set interfaces em1 unit 0 family inet address 10.1.1.10/24
D.R3:
interface Ethernet0/0
    ip address 10.1.1.3 255.255.255.0
    no shut
interface Loopback0
    ip address 3.3.3.3 255.255.255.255
三. JUNOS 静态路由配置:
A.配置方法:
set routing-options static route 0.0.0.0/0 next-hop 202.100.1.2
commit
B.测试:
root> ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=255 time=51.869 ms
^C
--- 1.1.1.1 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 51.869/51.869/51.869/nan ms
四.RIP动态路由配置:
--junos如果不配置认证,不用配置策略,配置认证,如果不配置策略,接口发出的rip包不会带有认证信息,junos只能接收rip。
A.JUNOS:
①配置策略:
set policy-options policy-statement advertis-routers-through-rip term 1 from protocol direct
set policy-options policy-statement advertis-routers-through-rip term 1 from protocol rip
set policy-options policy-statement advertis-routers-through-rip term 1 then accept
②配置接口,将接口加入group
set protocols rip group rip-group neighbor em1.0
③group export策略
set protocols rip group rip-group export advertis-routers-through-rip
④配置认证
全局:
set protocols rip authentication-type md5
set protocols rip authentication-key  cisco
接口:
set protocols rip group rip-group neighbor em1.0 authentication-type md5
set protocols rip group rip-group neighbor em1.0 authentication-key  cisco
B.R2:
①基本配置:
router rip
version 2
network 10.0.0.0
network 192.168.1.0
②配置认证:
key chain rip
key 1
  key-string cisco
interface Ethernet0/0
    ip rip authentication mode md5
    ip rip authentication key-chain rip
备注:测试时发现用c2691-adventerprisek9-mz.124-15.T14.BIN的2691的路由器配置完rip认证后,rip包中不会有认证信息,可能是IOS的问题。
C.验证:
root# run show route 

inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

3.0.0.0/8          *[RIP/100] 00:09:09, metric 2, tag 0
                   > to 10.1.1.3 via em1.0
10.1.1.0/24        *[Direct/0] 00:28:05
                   > via em1.0
10.1.1.10/32       *[Local/0] 00:28:05
                     Local via em1.0
13.0.0.0/8         *[RIP/100] 00:09:09, metric 2, tag 0
                   > to 10.1.1.3 via em1.0
202.100.1.0/24     *[Direct/0] 00:28:05
                   > via em0.0
202.100.1.10/32    *[Local/0] 00:28:05
                     Local via em0.0
224.0.0.9/32       *[RIP/100] 00:01:10, metric 1
                     MultiRecv
R3#show ip route rip
R    202.100.1.0/24 [120/1] via 10.1.1.10, 00:00:19, Ethernet0/0

五.OSPF动态路由配置:

A.R1:
router ospf 1
    router-id 1.1.1.1
    network 202.100.100.1 0.0.0.0 area 0
    network 1.1.1.1 0.0.0.0 a 0
interface Ethernet0/0
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco
---链路认证
B.R2:
router ospf 1
    router-id 2.2.2.2
    area 0 authentication message-digest
    network 202.100.1.2 0.0.0.0 area 0
    network 202.100.100.2 0.0.0.0 area 0
interface Ethernet0/0
    ip ospf message-digest-key 1 md5 cisco
interface Ethernet0/1
    ip ospf message-digest-key 1 md5 cisco
---区域认证
C.JUNOS:
set protocols ospf area 0.0.0.0 interface em0.0 authentication md5 1 key cisco
D:验证:
root# run show ospf neighbor
Address          Interface              State     ID               Pri  Dead
202.100.1.2      em0.0                  Full      2.2.2.2            1    32
root# run show route protocol ospf   

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32         *[OSPF/10] 00:00:04, metric 12
                   > to 202.100.1.2 via em0.0
202.100.100.0/24   *[OSPF/10] 04:48:10, metric 11
                   > to 202.100.1.2 via em0.0
224.0.0.5/32       *[OSPF/10] 04:48:22, metric 1
                     MultiRecv

六.OSPF和rip双向路由重分布配置:
A.RIP往OSPF:
①配置策略:
set policy-options policy-statement into-ospf term rip-to-ospf from protocol rip
set policy-options policy-statement into-ospf term rip-to-ospf from route-filter 3.0.0.0/8 exact
set policy-options policy-statement into-ospf term rip-to-ospf then accept
set policy-options policy-statement into-ospf term direct-to-ospf from protocol  direct
set policy-options policy-statement into-ospf term direct-to-ospf from route-filter 10.1.1.0/24 exact
set policy-options policy-statement into-ospf term direct-to-ospf then accept
set policy-options policy-statement into-ospf then reject
②调用策略:
set protocols ospf export into-ospf
③验证:
R1#show ip route ospf
O E2 3.0.0.0/8 [110/2] via 202.100.100.2, 00:07:57, Ethernet0/0
O    202.100.1.0/24 [110/20] via 202.100.100.2, 00:10:49, Ethernet0/0
    10.0.0.0/24 is subnetted, 1 subnets
O E2    10.1.1.0 [110/0] via 202.100.100.2, 00:00:04, Ethernet0/0
B. OSPF RIP
①配置策略:
set policy-options policy-statement into-rip term ospf-to-rip from protocol ospf
set policy-options policy-statement into-rip term ospf-to-rip from route-filter 202.100.100.0/24 exact
set policy-options policy-statement into-rip term ospf-to-rip from route-filter 1.1.1.1/32 exact
set policy-options policy-statement into-rip term ospf-to-rip then accept
set policy-options policy-statement into-rip term direct-to-rip from protocol direct
set policy-options policy-statement into-rip term direct-to-rip from route-filter 202.100.1.0/24 exact
set policy-options policy-statement into-rip term direct-to-rip then accept
set policy-options policy-statement into-rip then reject
②调用策略:
set protocols rip group rip-group export into-rip
③验证:
R3#show ip route rip
    1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.1.1.10, 00:00:24, Ethernet0/0
R    202.100.100.0/24 [120/1] via 10.1.1.10, 00:00:24, Ethernet0/0
R    202.100.1.0/24 [120/1] via 10.1.1.10, 00:00:24, Ethernet0/0




本文转自 碧云天 51CTO博客,原文链接:http://blog.51cto.com/333234/1355447,如需转载请自行联系原作者
相关文章
|
18天前
|
Web App开发 定位技术 iOS开发
Playwright 是一个强大的工具,用于在各种浏览器上测试应用,并模拟真实设备如手机和平板。通过配置 `playwright.devices`,可以轻松模拟不同设备的用户代理、屏幕尺寸、视口等特性。此外,Playwright 还支持模拟地理位置、区域设置、时区、权限(如通知)和配色方案,使测试更加全面和真实。例如,可以在配置文件中设置全局的区域设置和时区,然后在特定测试中进行覆盖。同时,还可以动态更改地理位置和媒体类型,以适应不同的测试需求。
Playwright 是一个强大的工具,用于在各种浏览器上测试应用,并模拟真实设备如手机和平板。通过配置 `playwright.devices`,可以轻松模拟不同设备的用户代理、屏幕尺寸、视口等特性。此外,Playwright 还支持模拟地理位置、区域设置、时区、权限(如通知)和配色方案,使测试更加全面和真实。例如,可以在配置文件中设置全局的区域设置和时区,然后在特定测试中进行覆盖。同时,还可以动态更改地理位置和媒体类型,以适应不同的测试需求。
19 1
|
2月前
|
JavaScript 测试技术 Windows
vue配置webpack生产环境.env.production、测试环境.env.development(配置不同环境的打包访问地址)
本文介绍了如何使用vue-cli和webpack为Vue项目配置不同的生产和测试环境,包括修改`package.json`脚本、使用`cross-env`处理环境变量、创建不同环境的`.env`文件,并在`webpack.prod.conf.js`中使用`DefinePlugin`来应用这些环境变量。
104 2
vue配置webpack生产环境.env.production、测试环境.env.development(配置不同环境的打包访问地址)
|
1月前
|
分布式计算 Hadoop Shell
Hadoop-35 HBase 集群配置和启动 3节点云服务器 集群效果测试 Shell测试
Hadoop-35 HBase 集群配置和启动 3节点云服务器 集群效果测试 Shell测试
69 4
|
1月前
|
运维 监控 数据可视化
大数据-171 Elasticsearch ES-Head 与 Kibana 配置 使用 测试
大数据-171 Elasticsearch ES-Head 与 Kibana 配置 使用 测试
63 1
|
1月前
|
存储 数据采集 分布式计算
Hadoop-17 Flume 介绍与环境配置 实机云服务器测试 分布式日志信息收集 海量数据 实时采集引擎 Source Channel Sink 串行复制负载均衡
Hadoop-17 Flume 介绍与环境配置 实机云服务器测试 分布式日志信息收集 海量数据 实时采集引擎 Source Channel Sink 串行复制负载均衡
44 1
|
1月前
|
监控 Java Maven
springboot学习二:springboot 初创建 web 项目、修改banner、热部署插件、切换运行环境、springboot参数配置,打包项目并测试成功
这篇文章介绍了如何快速创建Spring Boot项目,包括项目的初始化、结构、打包部署、修改启动Banner、热部署、环境切换和参数配置等基础操作。
130 0
|
2月前
|
JavaScript 测试技术
vue配置生产环境.env.production、测试环境.env.development
该文章介绍了如何在Vue项目中配置和使用不同的环境变量文件(.env、.env.production、.env.development)以适应开发、测试和生产环境,并通过修改`package.json`中的scripts来实现不同环境的打包。
458 0
vue配置生产环境.env.production、测试环境.env.development
|
9天前
|
JSON Java 测试技术
SpringCloud2023实战之接口服务测试工具SpringBootTest
SpringBootTest同时集成了JUnit Jupiter、AssertJ、Hamcrest测试辅助库,使得更容易编写但愿测试代码。
39 3
|
1月前
|
JSON 算法 数据可视化
测试专项笔记(一): 通过算法能力接口返回的检测结果完成相关指标的计算(目标检测)
这篇文章是关于如何通过算法接口返回的目标检测结果来计算性能指标的笔记。它涵盖了任务描述、指标分析(包括TP、FP、FN、TN、精准率和召回率),接口处理,数据集处理,以及如何使用实用工具进行文件操作和数据可视化。文章还提供了一些Python代码示例,用于处理图像文件、转换数据格式以及计算目标检测的性能指标。
59 0
测试专项笔记(一): 通过算法能力接口返回的检测结果完成相关指标的计算(目标检测)
|
2月前
|
移动开发 JSON Java
Jmeter实现WebSocket协议的接口测试方法
WebSocket协议是HTML5的一种新协议,实现了浏览器与服务器之间的全双工通信。通过简单的握手动作,双方可直接传输数据。其优势包括极小的头部开销和服务器推送功能。使用JMeter进行WebSocket接口和性能测试时,需安装特定插件并配置相关参数,如服务器地址、端口号等,还可通过CSV文件实现参数化,以满足不同测试需求。
240 7
Jmeter实现WebSocket协议的接口测试方法