开发者社区> 技术小阿哥> 正文

演示:配置日志发送到syslog日志服务器

简介:
+关注继续查看

演示目标:配置网络环境中的交换机和路由器将日志发送到syslog日志服务器。

演示环境:如下图10.54所示的演示环境。

142536357.png

演示背景:要求部署网络中的syslog服务器,集中的收集交换机S1和路由器R1所产生的日志,并且使用协议分析器,分析日志文件的构成和传输形式。

演示步骤:

spacer.gif第一步:完成基础配置,其中包括为交换机S1和路由器R1配置接口地址,必须确保交换机和路由器都能成功的与日志服务器192.168.3.100通信。


路由器R1上的基础配置:

R1(config)#interface e1/0

R1(config-if)#ip address 192.168.4.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit


R1(config)#interface e1/1

R1(config-if)#ip address 192.168.3.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit


在交换机S1上的基础配置:

S1(config)#interface vlan 1

S1(config-if)#ip address 192.168.4.100 255.255.255.0 *为交换机配置网络管理IP

S1(config-if)#no shutdown

S1(config-if)#exit

S1(config)#ip route 0.0.0.0 0.0.0.0192.168.4.1 *为交换机指定默认网关



注意:必须正确的在交换机S1上完成配置,保证交换机能成功的与日志服务器192.168.3.100通信,否则交换机S1所产生的日志将无法发送到192.168.3.100,事实上,此时的交换机S1在日志收集这个行为中,它就是一台被网络管理的IP结点,VLAN1接口上的IP地址192.168.4.100就是它的管理地址,而默认路由中的下一跳192.168.4.1就是交换机S1的默认网关



第二步:现在开始在日志服务器192.168.3.100上安装日志软件(kiwi syslog),在安装时需要注意,如下图10.54所示,选择将syslog以一个服务进行安装,而不是以应用程序,将syslog以一个服务进行安装时,不需要用户登陆windows系统,它就可以运行。


142637805.png

   安装完成后,如下图10.55所示,配置日志服务器所使用的IP地址、端口和日志的编码格式,默认情况下syslog使用UDP514号端口,请保持默认的日志编码格式。在完成上述配置后,打开日志的mange菜单,选择“start the syslogd service”以启动syslog服务。如下图10.56所示。

142736666.png

142859236.png

第三步:配置交换机S1和路由器R1支持日志功能,并将它们所产生的日志发送到日志服务器192.168.3.100上。具体配置如下:


配置交换机S1发送日志到192.168.3.100

S1(config)#logging on   *启动日志功能

S1(config)#logging host 192.168.3.100transport udp port 514  *申明日志服务器的IP和端口

S1(config)#logging source-interface vlan 1  *申明发送日志的更新源接口


配置交换机R1发送日志到192.168.3.100

R1(config)#logging on

R1(config)#logging host 192.168.3.100transport udp port 514

R1(config)#logging source-interface e1/1



第四步:现在来验证,交换机S1和路由器R1是否能将本地生产的日志成功的发送到日志服务器,你可以在交换机S1或者路由器R1的全局配置模式下,通过执行exit退出全局配置模式,就可以产生相关的日志。然后再到日志服务器192.168.3.100查看syslog服务,如下图10.57所示,syslog服务器成功的收集到S1和R1的日志。

143116646.png

   如果你在产生日志的同时开启了协议分析器,那么可以捕获到如下图10.58所示的日专协议数据帧,可清晰的看出发送日志的源主机和接收日志的目标主机,使用的端口号,日志的具体内容等,默认情况下日志是没有被加密的,以明文的行式体现。

143229737.png



本文转自 kingsir827 51CTO博客,原文链接:http://blog.51cto.com/7658423/1331801,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Kubernetes中Logtail日志采集CRD配置详解
日志采集配置默认支持控制台配置方式,同时针对Kubernetes微服务开发模式,我们还提供CRD的配置方式,您可以直接使用kubectl对配置进行管理。
5279 0
syslog-ng 系统配置
http://tech.ddvip.com/2009-02/1234012812107755_4.
522 0
利用MaxCompute内建函数及UDTF转换json格式日志数据
本文介绍了如何使用MaxCompute UDF对JSON格式的日志进行信息提取和转换。
9137 0
SpringBoot 2.x 日志配置 (logback配置文件配置)
错误日志 相信同学们已经对日志相关的操作已经很熟悉了,从SSM过来的同学肯定非常怀念那些日志的配置文件。那么SpringBoot 2.x 如何来配置自己的日志文件的配置文件以及日志输入呢? Spring Boot 项目结构 再resources 下面新增日志配置文件 logback-spring.
3290 0
向jboss写入服务器日志
实际开发中,记录日志是常用的功能,jboss默认情况下已经记录了很多运行日志,如果开发人员要手动在server.log中写入日志,可以参考下面的方法: 1 package utils; 2 3 import java.
755 0
手把手教你完成MaxCompute JDBC自定义日志配置
本文讲述了如何在MaxCompute JDBC 2.0 beta版本中完成日志功能的相关配置,并进一步对logback的配置文件进行了示例及说明。
5234 0
13690
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
JS零基础入门教程(上册)
立即下载
性能优化方法论
立即下载
手把手学习日志服务SLS,云启实验室实战指南
立即下载