hd1028Ignatius and the Princess III【母函数】

简介: Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12832    ...

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12832    Accepted Submission(s): 9080

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 
Sample Input
 
 
4 10 20
 
Sample Output
 
 
5 42 627
算法: 母函数
#include<cstdio>
int main()
{
    int n,i,j,k,a1[130],a2[130];
    for(i=0;i<=120;i++)
        {
            a1[i]=1;
            a2[i]=0;
        }
        for(i=2;i<=120;i++)
        {
            for(j=0;j<=120;j++)
            {
                for(k=0;k+j<=120;k+=i)
                {
                    a2[k+j]+=a1[j];
                }
            }
            for(j=0;j<=120;j++)
            {
                a1[j]=a2[j];
                a2[j]=0;
            }
        }
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",a1[n]);
    }
    return 0;
}
目录
相关文章
|
6月前
Knight Moves(POJ2243)
Knight Moves(POJ2243)
洛谷P2871-[USACO07DEC]Charm Bracelet S(01背包模板题)
洛谷P2871-[USACO07DEC]Charm Bracelet S(01背包模板题)
洛谷P2871-[USACO07DEC]Charm Bracelet S(01背包模板题)
hdu-1098 Ignatius's puzzle(费马小定理)
hdu-1098 Ignatius's puzzle(费马小定理)
154 0
hdu-1098 Ignatius's puzzle(费马小定理)
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1027,Ignatius and the Princess II
HDU-1027,Ignatius and the Princess II
HDU-1029,Ignatius and the Princess IV
HDU-1029,Ignatius and the Princess IV
|
Java C语言
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
138 0
|
人工智能
HDOJ 1028 Ignatius and the Princess III(递推)
HDOJ 1028 Ignatius and the Princess III(递推)
118 0