HDU-1029,Ignatius and the Princess IV

简介: HDU-1029,Ignatius and the Princess IV

Problem Description:


"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.


"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.


"But what is the characteristic of the special integer?" Ignatius asks.


"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.


Can you find the special integer for Ignatius?


Input:


The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.


Output:


For each test case, you have to output only one line which contains the special number you have found.


Sample Input:


5


1 3 2 3 3


11


1 1 1 1 1 5 5 5 5 5 5


7


1 1 1 1 1 1 1


Sample Output:


3


5


1


(唉,真的很难见到杭电有这么水的题了!!!)


程序代码:


#include<stdio.h>
#define N 1000000
int a[N];
int main()
{
  int i,n,t,ans;
  while(scanf("%d",&n)!=EOF)
  {
    for(i=0;i<n;i++)
    {
      scanf("%d",&t);
      a[t]++;
      if(a[t]>=(n+1)/2)
        ans=t;
    }
    printf("%d\n",ans);
  }
  return 0;
}

 


相关文章
|
7月前
|
机器学习/深度学习
N皇后问题(HDU—2253)
N皇后问题(HDU—2253)
|
7月前
|
机器学习/深度学习
HDU1210 Eddy's 洗牌问题
HDU1210 Eddy's 洗牌问题
LeetCode 70. 爬楼梯 Climbing Stairs
LeetCode 70. 爬楼梯 Climbing Stairs
|
人工智能 Java
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
Jumping Monkey Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 747 Accepted Submission(s): 360
229 0
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
|
算法 Go
HDU-1548,A strange lift(Dijkstra)
HDU-1548,A strange lift(Dijkstra)
|
人工智能
HDOJ 1028 Ignatius and the Princess III(递推)
HDOJ 1028 Ignatius and the Princess III(递推)
122 0