HDU-1027,Ignatius and the Princess II

简介: HDU-1027,Ignatius and the Princess II

Problem Description:


Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."


"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

Can you help Ignatius to solve this problem?


Input:


The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.


Output:


For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should prin


Sample Input:


6 4


11 8


Sample Output:


1 2 3 5 6 4


1 2 3 4 5 6 7 9 8 11 10


解题思路:


题目的大致意思就是一个全排列的问题,运用C++里的next_permutation函数就可以解决了,这个函数可以算出数的全排列,需要包含在#include<algorithm>头文件中。


程序代码:


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 1001
int main()
{
  int n,m,i,ans;
  int a[N];
  while(scanf("%d %d",&n,&m)!=EOF)
  {
    for(i=0;i<n;i++)
      a[i]=i+1;
    ans=0;
    do
    {
      ans++;
      if(ans==m)
      {
        for(i=0;i<n;i++)
        {
          if(i==n-1)
            printf("%d",a[i]);
          else
            printf("%d ",a[i]);
        }
        printf("\n");
        break;
      }
    }while(next_permutation(a,a+n));
  }
  return 0;
}


相关文章
|
算法 Java
HDU 2084 数塔
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的: 有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
178 0
|
人工智能 Java
HDU 1257
最少拦截系统 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4182    Accepted Submission(s): 1528 ...
784 0
|
人工智能 BI Java
HDU 1003
Max Sum Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 105228    Accepted Submission(s): 242...
899 0
|
机器学习/深度学习 人工智能
HDU 2674
  题意:求N!mod2009,N=41时,N!因式分解一定含7*7*41,即N!%2009=0.所以只要计算0
719 0