HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)

简介: HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)

此题无法用JavaAC,不相信的可以去HD1029题试下!


Problem Description

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.


“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.


“But what is the characteristic of the special integer?” Ignatius asks.


“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.


Can you find the special integer for Ignatius?


Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.


Output

For each test case, you have to output only one line which contains the special number you have found.


Sample Input

5

1 3 2 3 3

11

1 1 1 1 1 5 5 5 5 5 5

7

1 1 1 1 1 1 1


Sample Output

3

5

1



题意:就是在一行数中找出那个出现次数大于等于(n+1)/2的那个数,题目保证那个数只有一个!

此题有个坑,用Java无法AC,无论用桶排序,快排,还是DP都无法AC。会超时!

简单题,就不分析了。此处把Java代码也写上了。

AC的c语言代码:(后面有Java的(3种方法都用了))

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n;
    while(~scanf("%d",&n)){
        int i;
        int con=0;
        int m;
        int t;
        for(i=0;i<n;i++){
            scanf("%d",&t);
            if(con==0){
                m=t;
                con++;
            }else{
                if(t==m){
                    con++;
                }else{
                    con--;
                }
            }
        }
        printf("%d\n",m);
    }
    return 0;
}
目录
相关文章
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
129 0
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1029,Ignatius and the Princess IV
HDU-1029,Ignatius and the Princess IV
HDU-1027,Ignatius and the Princess II
HDU-1027,Ignatius and the Princess II
hdu-1098 Ignatius's puzzle(费马小定理)
hdu-1098 Ignatius's puzzle(费马小定理)
125 0
hdu-1098 Ignatius's puzzle(费马小定理)
Leetcode-Easy 70. Climbing Stairs
Leetcode-Easy 70. Climbing Stairs
79 0
Leetcode-Easy 70. Climbing Stairs
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
67 0
|
人工智能
HDOJ 1028 Ignatius and the Princess III(递推)
HDOJ 1028 Ignatius and the Princess III(递推)
98 0