HDOJ 1028 Ignatius and the Princess III(递推)

简介: HDOJ 1028 Ignatius and the Princess III(递推)

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.


“The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+…+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”


Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.


Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.


Sample Input

4

10

20


Sample Output

5

42

627



思路:

(i,j)(i>=j)代表的含义是i为n,j为划分的最大的数字。

边界:a(i,0) = a(i, 1) = a(0, i) = a(1, i) = 1;

i|j==0时,无论如何划分,结果为1;


当(i>=j)时,

划分为{j,{x1,x2…xi}},{x1,x2,…xi}的和为i-j,

{x1,x2,…xi}可能再次出现j,所以是(i-j)的j划分,所以划分个数为a(i-j,j);

划分个数还需要加上a(i,j-1)(累加前面的);


当(i < j)时,

a[i][j]就等于a[i][i];

import java.util.Scanner;
public class Main{
    static int a[][] = new int[125][125];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            System.out.println(a[n][n]);
        }
    }
    private static void dabiao() {
        for(int i=0;i<121;i++){
            a[i][0]=1;
            a[i][1]=1;
            a[0][i]=1;
            a[1][i]=1;
        }
        for(int i=2;i<121;i++){
            for(int j=2;j<121;j++){
                if(j<=i){
                    a[i][j]=a[i][j-1]+a[i-j][j];
                }else{
                    a[i][j]=a[i][i];
                }
            }
        }
    }
}


目录
相关文章
|
算法
hdoj 4712 Hamming Distance(靠人品过的)
在信息论中,两个等长字符串之间的汉明距离是两个字符串对应位置的字符不同的个数。换句话说,它就是将 一个字符串变换成另外一个字符串所需要替换的字符个数。
38 0
hdoj 1078 FatMouse and Cheese(记忆化搜索)
简单的记忆化搜索,和其他不一样的地方就是这个一次可以走K步,其他没啥!!
56 0
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDOJ 1098 Ignatius's puzzle
HDOJ 1098 Ignatius's puzzle
122 0
|
C语言
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
102 0
|
Java
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
104 0
|
算法
HDOJ/HDU 1015 Safecracker(深搜)
HDOJ/HDU 1015 Safecracker(深搜)
104 0
|
Java
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
103 0
|
Java
HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)
HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)
102 0
|
测试技术
HDOJ(HDU) 1859 最小长方形(水题、、)
HDOJ(HDU) 1859 最小长方形(水题、、)
81 0