【YashanDB知识库】YAS-02547 there is a gap in the restored archived logs on instance 1, reason: start of restored archive 35 is greater than database last archive 21

简介: 【YashanDB知识库】YAS-02547 there is a gap in the restored archived logs on instance 1, reason: start of restored archive 35 is greater than database last archive 21

本文内容来自YashanDB官网,原文内容请见 https://www.yashandb.com/newsinfo/7849017.html?templateId=1718516

【标题】错误码处理

【问题分类】执行数据库归档注册时报错

【关键字】YAS-02547

【问题描述】执行restore archivelog sequence between xxx and yyy thread 1 from searchdir '/tmp/d1' ; 语句后触发报错。

【问题原因分析】

# YAS-02547 there is a gap in the restored archived logs on instance 1, reason: start of restored archive 35 is greater than database last archive 21

# 由于数据库中当前注册的最新归档号为21,在恢复归档文件时,必须从下一个归档(22号归档)开始进行恢复。

# 在实际恢复中,指定的归档范围中最早的归档号为35,因此触发报错。

【解决/规避方法】按归档生成的顺序依次进行恢复,不能跳过更早的归档,直接恢复更新的归档。

【影响范围】-

【修复版本】-

相关文章
|
SQL 数据库
【YashanDB知识库】YAS-02605 the current instance is not master role
【YashanDB知识库】在共享集群架构数据库上实施恢复,触发报错
|
SQL 数据库
【YashanDB 知识库】YAS-02605 the current instance is not master role
【YashanDB 知识库】YAS-02605 the current instance is not master role
|
数据库
【YashanDB知识库】安装共享集群时报错:YAS-05721 invalid input parameter, reason: node name invalid
【YashanDB知识库】安装共享集群时报错:YAS-05721 invalid input parameter, reason: node name invalid
|
数据库
【YashanDB知识库】YAS-02547 there is a gap in the restored archived logs on instance 1, reason: start of restored archive 35 is greater than database last archive 21
【YashanDB知识库】YAS-02547 there is a gap in the restored archived logs on instance 1, reason: start of restored archive 35 is greater than database last archive 21
|
SQL Oracle 关系型数据库
WARNING: Too Many Parse Errors With error=911 When Running a JDBC Application Connected to an Oracle 19c database
WARNING: Too Many Parse Errors With error=911 When Running a JDBC Application Connected to an Oracle 19c database (
656 2
|
Oracle 关系型数据库
19c 开启Oracle Database Vault
19c 开启Oracle Database Vault
516 1
|
SQL Oracle 关系型数据库
Connect to Autonomous Database Using Oracle Database Tools
Connect to Autonomous Database Using Oracle Database Tools
659 156
|
人工智能 Oracle 关系型数据库
一篇文章弄懂Oracle和PostgreSQL的Database Link
一篇文章弄懂Oracle和PostgreSQL的Database Link
|
Oracle 关系型数据库 Linux
Requirements for Installing Oracle Database/Client 19c on OL8 or RHEL8 64-bit (x86-64) (Doc ID 2668780.1)
Requirements for Installing Oracle Database/Client 19c on OL8 or RHEL8 64-bit (x86-64) (Doc ID 2668780.1)
392 0
|
Oracle 关系型数据库 数据库
windows Oracle Database 19c 卸载教程
打开任务管理器 ctrl+Shift+Esc可以快速打开任务管理器,找到oracle所有服务然后停止。 停止数据库服务 在开始卸载之前,确保数据库服务已经停止。你可以使用以下命令停止数据库服务: net stop OracleServiceORCL Universal Installer 卸载Oracle数据库程序 一般情况运行Oracle自带的卸载程序,如使用Universal Installer 工具卸载。 点击开始菜单找到Oracle,然后点击Oracle安装产品,再点击Universal Installer。 点击之后稍等一会然后会进入进入下图界面,点击卸载产品。 选中要删除的Orac
2908 1

热门文章

最新文章