HDU 1114 Piggy-Bank (完全背包)

简介: HDU 1114 Piggy-Bank (完全背包)



Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17253    Accepted Submission(s): 8693


Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.


But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 


Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 


Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 


Sample Input

      3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4      

 


Sample Output

      The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.      

 


Source

Central Europe 1999

 


Recommend

Eddy   |   We have carefully selected several similar problems for you:   2191  1203  1059  1074  1024

 


题意分析:  意思是求把钱灌装满后罐内最少有多少钱

数据分析:

 3                有三组数据
10 110         钱罐重10克   装满钱后重 110克(也就是说需要装110-10=100克钱)
2                   共有 2 种钱
1 1                第一种钱  一个是  1 元   重  1克
30 50            第二种钱  一个是  30元  重  50克
第一组数据   如果装 1 元的   那么装100克  是100元

装  30元的 正好装两张 100克(50+5=100克)  是30+30=60元 所以就是他了装两张30元的最优



10 110           同理
2
1 1
50 30

1 6
2
10 3
20 4



代码就不详解了不懂的   点这里  




#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f
using namespace std;
int dp[10010];
int wight[600],value[600];
int main()
{
  int t;
  scanf("%d",&t);
  while(t--)
  {
    int emptyw,fullw,n;
    scanf("%d%d%d",&emptyw,&fullw,&n);
      for(int i=0;i<n;i++)
         scanf("%d%d",&value[i],&wight[i]);
      memset(dp,INF,sizeof(dp));
      dp[0]=0;
      int tw=fullw-emptyw;
      for(int i=0;i<n;i++)
        for(int j=wight[i];j<=tw;j++)
            if(dp[j-wight[i]]<INF)
               dp[j]=min(dp[j],dp[j-wight[i]]+value[i]); 
     if(dp[tw]>=INF) printf("This is impossible.\n");
     else   printf("The minimum amount of money in the piggy-bank is %d.\n",dp[tw]);         
  }
  return 0;
}





目录
相关文章
|
8月前
|
算法
poj 1050 To the Max(最大子矩阵之和)
poj 1050 To the Max(最大子矩阵之和)
26 0
|
7月前
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
33 0
|
知识图谱
POJ-1384,Piggy-Bank(完全背包)
POJ-1384,Piggy-Bank(完全背包)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
90 0
|
Java 知识图谱
|
容器
hdu3388 Coprime【容斥原理】
Problem Description Please write a program to calculate the k-th positive integer that is coprime with m and n simultaneously.
1115 0