HDU-1008,Elevator(水题)

简介: HDU-1008,Elevator(水题)

Problem Description:


The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.


For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input:


There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.


Output:


Print the total time on a single line for each test case.  


Sample Input:


1 2


3 2 3 1


0


Sample Output:


17


41


程序代码:

#include<stdio.h>
#include<string.h>
int main()
{
  int n,a,b,sum;
  while(~scanf("%d",&n)&&n)
  {
    sum=b=0;
    while(n--)
    {
      scanf("%d",&a);
      if(b<a)
      {
        sum+=(a-b)*6+5;
        b=a;
      }
      else if(b>a)
      {
        sum+=(b-a)*4+5;
        b=a;
      }
      else
        sum+=5;
    }
    printf("%d\n",sum);
  }
  return 0;
}


相关文章
HDOJ/HDU 2560 Buildings(嗯~水题)
HDOJ/HDU 2560 Buildings(嗯~水题)
113 0
HDOJ/HDU 2560 Buildings(嗯~水题)
HDU-1097,A hard puzzle(快速幂)
HDU-1097,A hard puzzle(快速幂)
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
135 0
HDOJ/HDU 2551 竹青遍野(打表~)
HDOJ/HDU 2551 竹青遍野(打表~)
107 0
HDOJ(HDU) 2090 算菜价(简单水题、)
HDOJ(HDU) 2090 算菜价(简单水题、)
180 0
HDOJ(HDU) 1718 Rank(水题、、、)
HDOJ(HDU) 1718 Rank(水题、、、)
97 0
|
算法
HDOJ/HDU 1015 Safecracker(深搜)
HDOJ/HDU 1015 Safecracker(深搜)
98 0
HDOJ(HDU) 2503 a/b + c/d(最大公约数问题)
HDOJ(HDU) 2503 a/b + c/d(最大公约数问题)
131 0