HDU-1213,How Many Tables(并查集水题)

简介: HDU-1213,How Many Tables(并查集水题)

Problem Description:


Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.


Input:


The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.


Output:


For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.


Sample Input:


2

5 3

1 2

2 3

4 5

5 1

2 5


Sample Output:


2

4


程序代码:


#include<iostream>
#include<cstdio>
using namespace std;
int n,m,f[1001];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
}
int main()
{
  int t,x,y,sum;
  scanf("%d",&t);
  while(t--)
  {
    sum=0;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++)
      f[i]=i;
    for(int i=1;i<=m;i++)
    {
      scanf("%d %d",&x,&y);
      merge(x,y);
    }
    for(int i=1;i<=n;i++)
    {
      if(f[i]==i)
        sum++;
    }
    printf("%d\n",sum);
  }
  return 0;
}
相关文章
|
1月前
|
机器学习/深度学习
N皇后问题(HDU—2253)
N皇后问题(HDU—2253)
|
8月前
华为机试HJ44:Sudoku(数独问题,深度优先遍历DFS解法)
华为机试HJ44:Sudoku(数独问题,深度优先遍历DFS解法)
|
10月前
UVa11420 - Chest of Drawers(动态规划)
UVa11420 - Chest of Drawers(动态规划)
34 0
|
10月前
UVa668 - Parliament(贪心)
UVa668 - Parliament(贪心)
39 0
|
算法 C++
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
95 0
|
Java BI 机器学习/深度学习
|
人工智能 BI 存储