POJ-1384,Piggy-Bank(完全背包)

简介: POJ-1384,Piggy-Bank(完全背包)

Description:


Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.


But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!  


Input:


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.  


Output:


Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".


Sample Input:


3


10 110


2


1 1


30 50


10 110


2


1 1


50 30


1 6


2


10 3


20 4


Sample Output:


The minimum amount of money in the piggy-bank is 60.


The minimum amount of money in the piggy-bank is 100.


This is impossible.


解题思路:


这是一个完全背包的问题,多组数据;

给定存钱罐的初始重量和最终重量,给定n种货币的价值,重量;

求恰好满足存钱罐的最终重量的货币总钱数最小值。若不满足,按题目要求输出“XXX”。  


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100001
#define INF 0x3f3f3f3f
int dp[N],w[N],v[N];
int t,x,y,n,sum;
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d %d",&x,&y);
    sum=y-x;//存钱罐的净容量 
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
      scanf("%d %d",&w[i],&v[i]);
    for(int i=1;i<=sum;i++)//因为要求刚好装满,所以只需将这个范围的dp[]赋值为无穷 
      dp[i]=INF;
    for(int i=1;i<=n;i++)
    {
      for(int j=v[i];j<=sum;j++)//从小到大递增的顺序 
      {
        dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
      }
    }
    if(dp[sum]!=INF)
      printf("The minimum amount of money in the piggy-bank is %d.\n",dp[sum]);
    else
      printf("This is impossible.\n");
  }
  return 0;
}

 


相关文章
|
存储
poj 3254 Corn Fields (状态压缩dp)
状态压缩dp其实就是用二进制来表示所有的状态,比如这题, 我们在某一行可以这样取0 1 0 1 1 0 1,用1代表取了,0代表没取,因为这点,它的数据量也限制在20以内,所有看到这样数据量的题目可以先考虑一下状态压缩dp。对于有多行的数据,所有状态的总数必然很庞大,而且不用特殊的方法想要存储这些状态是不太现实的。既然每个点只有这两种情况,我们可以用二进制的一位来表示,0 1 0 1 1 0 1就可以表示为二进制0101101也就是十进制的45,如果我们想要枚举6个点的所有状态,我们只需要从0到2^6取其二进制就可以了,并不会重复或是多余。
32 0
|
6月前
|
Java 数据挖掘 知识图谱
HDU 1114 Piggy-Bank (完全背包)
HDU 1114 Piggy-Bank (完全背包)
34 0
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
Java 测试技术
HDU 1248 寒冰王座(完全背包裸题)
寒冰王座 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17092    Accepted Submission(s): 8800 ...
1214 0
|
Java
HDU 2546 饭卡(01背包裸题)
饭卡 Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 28562    Accepted Submission(s): 9876 Problem Description 电子科大本部食堂的饭卡有一种很诡异的设计,即在购买之前判断余额。
1104 0
|
人工智能 Java
组合数学 - 母函数的运用 --- hdu 1709 :The Balance
The Balance Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5706    Accepted Submission(s): 2...
846 0