POJ-1384,Piggy-Bank(完全背包)

简介: POJ-1384,Piggy-Bank(完全背包)

Description:


Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.


But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!  


Input:


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.  


Output:


Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".


Sample Input:


3


10 110


2


1 1


30 50


10 110


2


1 1


50 30


1 6


2


10 3


20 4


Sample Output:


The minimum amount of money in the piggy-bank is 60.


The minimum amount of money in the piggy-bank is 100.


This is impossible.


解题思路:


这是一个完全背包的问题,多组数据;

给定存钱罐的初始重量和最终重量,给定n种货币的价值,重量;

求恰好满足存钱罐的最终重量的货币总钱数最小值。若不满足,按题目要求输出“XXX”。  


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100001
#define INF 0x3f3f3f3f
int dp[N],w[N],v[N];
int t,x,y,n,sum;
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d %d",&x,&y);
    sum=y-x;//存钱罐的净容量 
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
      scanf("%d %d",&w[i],&v[i]);
    for(int i=1;i<=sum;i++)//因为要求刚好装满,所以只需将这个范围的dp[]赋值为无穷 
      dp[i]=INF;
    for(int i=1;i<=n;i++)
    {
      for(int j=v[i];j<=sum;j++)//从小到大递增的顺序 
      {
        dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
      }
    }
    if(dp[sum]!=INF)
      printf("The minimum amount of money in the piggy-bank is %d.\n",dp[sum]);
    else
      printf("This is impossible.\n");
  }
  return 0;
}

 


相关文章
|
6月前
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
27 0
|
7月前
|
BI
poj 1976 A Mini Locomotive(01背包)
题目的大概意思就是说给你n个数,然后就是有三辆货车头可以拉连续k辆车厢,问你这三个火车头最终可以拉的最大的乘客数是多少。
24 0
洛谷P2722-[USACO3.1]总分 Score Inflation(完全背包)
洛谷P2722-[USACO3.1]总分 Score Inflation(完全背包)
洛谷P2722-[USACO3.1]总分 Score Inflation(完全背包)
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
84 0
UVa 11292 - Dragon of Loowater(排序贪心)
UVa 11292 - Dragon of Loowater(排序贪心)
74 0
|
人工智能 Java
HDU 1003 Max Sum【动态规划求最大子序列和详解 】
Max Sum Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 250714    Accepted Submission(s): 593...
1252 0
|
C++
LeetCode 198 House Robber(强盗盗窃最大值)(动态规划)(*)
版权声明:转载请联系本人,感谢配合!本站地址:http://blog.csdn.net/nomasp https://blog.csdn.net/NoMasp/article/details/50560560 翻译 你是一个专业强盗,并计划沿街去盗窃每一个住户。
907 0
LeetCode 70 Climbing Stairs(爬楼梯)(动态规划)(*)
版权声明:转载请联系本人,感谢配合!本站地址:http://blog.csdn.net/nomasp https://blog.csdn.net/NoMasp/article/details/50514606 翻译 你正在爬一个楼梯。
911 0