数据结构实验之查找一:二叉排序树

简介: 数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400 ms Memory Limit: 65536 KiB

SubmitStatistic

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Sample Input

4 2

3 1 4 2

3 4 1 2

3 2 4 1

2 1

2 1

1 2

0

Sample Output

Yes

No

No

Hint

 

Source

xam

思路:套模板建立二叉排序树,输出前序遍历,比较相不相同。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    int data;
    struct node *lc;
    struct node *rc;
};
int k, l, a[1100], b[1100];
struct node *creat(struct node *root, int x)
{
    if(root == NULL)
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->data = x;
        root->lc = NULL;
        root->rc = NULL;
    }
    else
    {
        if(x < root->data)
        {
            root->lc = creat(root->lc, x);
        }
        else
        {
            root->rc = creat(root->rc, x);
        }
    }
    return root;
};
void str1(struct node *root)
{
    if(root)
    {
        a[k++] = root->data;
        str1(root->lc);
        str1(root->rc);
    }
}
void str2(struct node *root)
{
    if(root)
    {
        b[l++] = root->data;
        str2(root->lc);
        str2(root->rc);
    }
}
int main()
{
    int n, m, x, i;
    struct node *root, *root1;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        if(n == 0)
        {
            break;
        }
        else
        {
            root = NULL;
            for(i = 0; i < n; i++)
            {
                scanf("%d", &x);
                root = creat(root, x);
            }
            k = 0;
            memset(a, 0, sizeof(a));
            str1(root);
            while(m--)
            {
                l = 0;
               root1 = NULL;
               for(i = 0; i < n; i++)
               {
                   scanf("%d", &x);
                   root1 = creat(root1, x);
               }
               memset(b, 0, sizeof(b));
               str2(root1);
               for(i = 0; i < n; i++)
               {
                   if(a[i] != b[i])
                   {
                       break;
                   }
               }
               if(i == n)
               {
                   printf("Yes\n");
               }
               else
               {
                   printf("No\n");
               }
            }
        }
    }
    return 0;
}

个人感觉这种办法并不是最好的,最好的办法应该直接比较树的子树的大小。代码的意思如下

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data;
    struct node *lc;
    struct node *rc;
};
struct node *creat(struct node *root, int x)
{
    if(root == NULL)
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->lc = NULL;
        root->rc = NULL;
        root->data = x;
    }
    else
    {
        if(x > root->data)
        {
            root->rc = creat(root->rc, x);
        }
        else
        {
            root->lc = creat(root->lc, x);
        }
    }
    return root;
};
int flag;
void bijiao(struct node *root, struct node *root1)
{
    if(root != 0 && root1 != 0)
    {
        if(root->data != root1->data)
        {
            flag = 1;
            return;
        }
        bijiao(root->lc, root1->lc);
        bijiao(root->rc, root1->rc);
    }
}
int main()
{
    int n, i, len1, len2;
    char a[11], b[11];
    struct node *root;
    struct node *root1;
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0)
        {
            break;
        }
        else
        {
            scanf("%s", a);
            len1 = strlen(a);
            root = NULL;
            for(i = 0; i < len1; i++)
            {
                root = creat(root, a[i]);
            }
            while(n--)
            {
                flag = 0;
                scanf("%s", b);
                len2 = strlen(b);
                root1 = NULL;
                for(i = 0; i < len2; i++)
                {
                    root1 = creat(root1, b[i]);
                }
                bijiao(root, root1);
                if(flag == 0)
                {
                    printf("YES\n");
                }
                else
                {
                    printf("NO\n");
                }
            }
        }
    }
    return 0;
}


相关文章
|
5月前
|
存储 算法 数据安全/隐私保护
【Python学习篇】Python实验小练习——高级数据结构(五)
【Python学习篇】Python实验小练习——高级数据结构(五)
65 1
|
1月前
|
存储 算法 数据管理
数据结构与算法学习二零:二叉排序树(BST)、平衡二叉树(AVL)
这篇文章通过需求分析、代码实现和测试验证,详细介绍了二叉排序树的创建、遍历和删除操作,以及二叉平衡树(AVL)的自平衡特性和单旋转操作,旨在提高树结构在数据管理中的效率和性能。
30 0
数据结构与算法学习二零:二叉排序树(BST)、平衡二叉树(AVL)
|
5月前
|
存储 算法 数据挖掘
数据结构实验||约瑟夫环
数据结构实验||约瑟夫环
|
1月前
|
算法
计科一二班算法数据结构实验9答案
计科一二班算法数据结构实验9答案
14 0
|
2月前
|
存储 C语言
数据结构基础详解(C语言): 树与二叉树的应用_哈夫曼树与哈夫曼曼编码_并查集_二叉排序树_平衡二叉树
本文详细介绍了树与二叉树的应用,涵盖哈夫曼树与哈夫曼编码、并查集以及二叉排序树等内容。首先讲解了哈夫曼树的构造方法及其在数据压缩中的应用;接着介绍了并查集的基本概念、存储结构及优化方法;随后探讨了二叉排序树的定义、查找、插入和删除操作;最后阐述了平衡二叉树的概念及其在保证树平衡状态下的插入和删除操作。通过本文,读者可以全面了解树与二叉树在实际问题中的应用技巧和优化策略。
|
6月前
|
存储 算法
数据结构实验(四)二叉树的基本操作
数据结构实验(四)二叉树的基本操作
|
6月前
|
存储 算法
数据结构实验(三)
数据结构实验(三)
实验:数据结构(结构体在单链表中的增删改查)
实验:数据结构(结构体在单链表中的增删改查)
|
6月前
|
存储 机器学习/深度学习 算法
上机实验三 图的最小生成树算法设计 西安石油大学数据结构
上机实验三 图的最小生成树算法设计 西安石油大学数据结构
86 1
|
6月前
|
存储 算法 C语言
上机实验四 图的最小生成树算法设计 西安石油大学数据结构
上机实验四 图的最小生成树算法设计 西安石油大学数据结构
56 1

热门文章

最新文章