【PAT甲级 - C++题解】1154 Vertex Coloring

简介: 【PAT甲级 - C++题解】1154 Vertex Coloring

1154 Vertex Coloring

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.


Now you are supposed to tell if a given coloring is a proper k-coloring.


Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.


After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.


Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.


Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9


Sample Output:

4-coloring
No
6-coloring
No


题意

一个合适的顶点着色是指用各种颜色标记图中各个顶点,使得每条边的两个端点的颜色都不相同。

如果一种合适的顶点着色方案使用了一共 k 种不同的颜色,则称其为合适的 k 着色(k-coloring)。

现在,你需要判断给定的着色方案是否是合适的 k 着色方案。


思路

1.直接用一个结构体数组 e 来存储每一条边。

2.输入每种染色方案后,遍历每一条边,判断是否每一条边都满足两个点的颜色都不相同,只要有一个边出现两点颜色相同,则都不是一个合法的着色方案。

3.根据判断结果输出答案,我们可以用一个 set 容器来对颜色进行去重,set 容器会帮我们将相同的值去掉。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 10010;
struct Edge {
    int a, b;
}e[N];
int n, m;
int color[N];
int main()
{
    cin >> n >> m;
    //输入每条边
    for (int i = 0; i < m; i++)    cin >> e[i].a >> e[i].b;
    //开始查询
    int k;
    cin >> k;
    while (k--)
    {
        //输入每种染色方案
        for (int i = 0; i < n; i++)  cin >> color[i];
        //判断每条边的两个点颜色是否都是不同
        bool success = true;
        for (int i = 0; i < m; i++)
            if (color[e[i].a] == color[e[i].b])
            {
                success = false;
                break;
            }
        if (success)
        {
            //可以用set来对颜色进行去重
            unordered_set<int> s;
            for (int i = 0; i < n; i++)  s.insert(color[i]);
            printf("%d-coloring\n", s.size());
        }
        else puts("No");
    }
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
80 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
135 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
58 0
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
71 0
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
65 0