【PAT甲级 - C++题解】1091 Acute Stroke

简介: 【PAT甲级 - C++题解】1091 Acute Stroke

1091 Acute Stroke


One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.


Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).


Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


6d3dfd98579f478aa23358f978fff3f0.jpg

Figure 1


Output Specification:

For each case, output in a line the total volume of the stroke core.


Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26


题意

这题实际上就是一个求连通块数量的题目,给定一个 L×M×N 的三维矩阵和一个常量 T ,每个坐标只与其上下左右前后相连通,一个连通块的面积大于等于 T 就算危险中风区域,现在要求我们计算该三维矩阵中危险中风区域的总面积。


思路

由于 PAT 的内存限制,如果用 dfs 会爆栈,所以这题我们用 bfs 来做,具体思路如下:


1.输入地图,用一个三维数组 g 来存储,1 表示中风区域,0 表示正常区域。

2.遍历数组中的每一个坐标,如果该位置是中风区域,则计算与其相连通的区域面积。

①bfs 需要用到队列,初始化队列,同时在数组 g 中标记当前坐标为 0 即表示已遍历过。

②每次遍历都从队列头部取出一个元素,然后判断其相邻的六个方向是否可达即同样也是中风区域,如果是则将该坐标加入到队列的尾部。

③每加入一个坐标到队列,当前连通块面积 cnt 就加 1 。

3.如果当前遍历的连通块面积大于等于 T ,就加入到总面积 res 当中。

4.输出危险中风总面积 res 。


代码

#include<bits/stdc++.h>
using namespace std;
const int M = 1300, N = 130, L = 65;
int g[L][M][N];
int m, n, l, T;
struct Node {
    int x, y, z;
};
int d[][3] = {
    {1,0,0},
    {-1,0,0},
    {0,1,0},
    {0,-1,0},
    {0,0,1},
    {0,0,-1}
};
//宽度优先搜索求连通块面积
int bfs(int x, int y, int z)
{
    //初始化
    queue<Node> q;
    q.push({ x,y,z });
    g[x][y][z] = 0;
    //开始宽搜
    int cnt = 1;
    while (q.size())
    {
        auto t = q.front();
        q.pop();
        //遍历6个方向
        for (int i = 0; i < 6; i++)
        {
            int a = t.x + d[i][0], b = t.y + d[i][1], c = t.z + d[i][2];
            if (a >= 0 && a < l && b >= 0 && b < m && c >= 0 && c < n && g[a][b][c])
            {
                g[a][b][c] = 0;
                q.push({ a,b,c });
                cnt++;
            }
        }
    }
    return cnt;
}
int main()
{
    //输入地图
    scanf("%d%d%d%d", &m, &n, &l, &T);
    for (int i = 0; i < l; i++)
        for (int j = 0; j < m; j++)
            for (int k = 0; k < n; k++)
                scanf("%d", &g[i][j][k]);
    //计算危险中风区域面积
    int res = 0;
    for (int i = 0; i < l; i++)
        for (int j = 0; j < m; j++)
            for (int k = 0; k < n; k++)
                if (g[i][j][k])
                {
                    int cnt = bfs(i, j, k);
                    if (cnt >= T)  res += cnt;
                }
    //输出总面积
    printf("%d\n", res);
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
76 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
107 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
94 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
95 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
85 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
90 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
154 0
|
2天前
|
编译器 C语言 C++
类和对象的简述(c++篇)
类和对象的简述(c++篇)
|
1月前
|
C++ 芯片
【C++面向对象——类与对象】Computer类(头歌实践教学平台习题)【合集】
声明一个简单的Computer类,含有数据成员芯片(cpu)、内存(ram)、光驱(cdrom)等等,以及两个公有成员函数run、stop。只能在类的内部访问。这是一种数据隐藏的机制,用于保护类的数据不被外部随意修改。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。成员可以在派生类(继承该类的子类)中访问。成员,在类的外部不能直接访问。可以在类的外部直接访问。为了完成本关任务,你需要掌握。
68 19
|
1月前
|
存储 编译器 数据安全/隐私保护
【C++面向对象——类与对象】CPU类(头歌实践教学平台习题)【合集】
声明一个CPU类,包含等级(rank)、频率(frequency)、电压(voltage)等属性,以及两个公有成员函数run、stop。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。​ 相关知识 类的声明和使用。 类的声明和对象的声明。 构造函数和析构函数的执行。 一、类的声明和使用 1.类的声明基础 在C++中,类是创建对象的蓝图。类的声明定义了类的成员,包括数据成员(变量)和成员函数(方法)。一个简单的类声明示例如下: classMyClass{ public: int
50 13