CF788A Functions again

简介: CF788A Functions again

题目描述

Something happened in Uzhlyandia again… There are riots on the streets… Famous Uzhlyandian superheroes Shean the Sheep and Stas the Giraffe were called in order to save the situation. Upon the arriving, they found that citizens are worried about maximum values of the Main Uzhlyandian Function f f , which is defined as follows:


In the above formula, 1<=l<r<=n must hold, where n n is the size of the Main Uzhlyandian Array a a , and ∣x∣ means absolute value of x . But the heroes skipped their math lessons in school, so they asked you for help. Help them calculate the maximum value of f among all possible values of l l and r r for the given array a .


输入输出格式

输入格式:

The first line contains single integer n ( 2<=n<=10^5) — the size of the array a.

The second line contains n integers a1, a2, …, an (-10^9 ≤ ai ≤ 10^9) — the array elements.


输出格式:

Print the only integer — the maximum value of f .


输入输出样例

输入样例#1:

5

1 4 2 3 1

输出样例#1:

3

输入样例#2:

4

1 5 4 7

输出样例#2:

6

说明

In the first sample case, the optimal value of f is reached on intervals [1,2] and [2,5] .


In the second case maximal value of f is reachable only on the whole array.

如果奇数位开始,那么奇数位必为正,偶数位必为负


反之,如果从偶数位开始,那么偶数位必为正,奇数位也必为负


只要分奇偶循环各自走一遍,求最大和就好了

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2e6 + 5;
typedef long long ll;
int a[maxn], b[maxn];
ll find(int l, int r) {
  ll res = 0, ans = b[l];
  for (int i = l; i <= r; i++) {
    if (res < 0) res = 0;
    res += b[i];
    ans = max(ans, res);
  }
  return ans;
}
int main() {
  int n, m;
  scanf("%d", &n);
  for (int i = 1; i <= n; i++) {
    scanf("%d", &a[i]);
  }
  for (int i = 1; i <= n - 1; i++) {
    if (i & 1)b[i] = abs(a[i] - a[i + 1]);
    else b[i] -= abs(a[i] - a[i + 1]);
  }
  ll ans = 0;
  ans = max(ans, find(1, n - 1));
  for (int i = 1; i <= n - 1; i++) b[i] = -b[i];
  ans = max(ans, find(1, n - 1));
  printf("%lld\n", ans);
  return 0;
}
相关文章
|
5月前
No rule to make target ‘.xxxxxxxx‘, needed by ‘debug/xxxx.cpp‘. Stop.
No rule to make target ‘.xxxxxxxx‘, needed by ‘debug/xxxx.cpp‘. Stop.
OMP: Error #15: Initializing libiomp5md.dll, but found libiomp5md.dll already initialized.
OMP: Error #15: Initializing libiomp5md.dll, but found libiomp5md.dll already initialized.
relocation R_X86_64_PC32 against symbol ff_pw_9 can not be used when making a shared object
relocation R_X86_64_PC32 against symbol ff_pw_9 can not be used when making a shared object
286 0
|
Ubuntu
Could not load dynamic library 'libcudnn.so.8'
Could not load dynamic library 'libcudnn.so.8'
918 0
|
编解码 计算机视觉
成功解决[libopenh264 @ 000001dc01594420] Incorrect library version loaded
成功解决[libopenh264 @ 000001dc01594420] Incorrect library version loaded
|
Java Shell PHP
Guidelines for Function Compute Development - Use Fun Local for Local Running and Debugging
Preface The following key concepts are involved in this document: Function Compute: an event-driven service that allows you to focus on writing and .
1781 0
|
人工智能 大数据
Transaction Check Error:file /usr/libexec/getconf/default conflicts between attempted installs of gcc-6.4.1-1.fc25.i686 and gcc-6.4.1-1.fc25.x86_64
欢迎关注大数据和人工智能技术文章发布的微信公众号:清研学堂,在这里你可以学到夜白(作者笔名)精心整理的笔记,让我们每天进步一点点,让优秀成为一种习惯! 今天在我的ubuntu系统上使用yum来安装软件时出错了错误:Transaction Check Error:file /usr/libexec/...
1455 0