Linux驱动开发笔记(二):ubuntu系统从源码编译安装gcc7.3.0编译器

简介: 编译ubuntu驱动之前,发现使用的gcc是7.3.0,而使用apt管理和下载的都无法直接或间接安装gcc7.3.0,于是只能从源码安装gcc7.3.0编译器。

前言

  编译ubuntu驱动之前,发现使用的gcc是7.3.0,而使用apt管理和下载的都无法直接或间接安装gcc7.3.0,于是只能从源码安装gcc7.3.0编译器。


GCC

概述

  GCC是以GPL许可证所发行的自由软件,也是GNU计划的关键部分。GCC的初衷是为GNU操作系统专门编写一款编译器,现已被大多数类Unix操作系统(如Linux、BSD、MacOS X等)采纳为标准的编译器,甚至在微软的Windows上也可以使用GCC。GCC支持多种计算机体系结构芯片,如x86、ARM、MIPS等,并已被移植到其他多种硬件平台。

  GCC原名为GNU C语言编译器(GNU C Compiler),只能处理C语言。但其很快扩展,变得可处理C++,后来又扩展为能够支持更多编程语言,如Fortran、Pascal、Objective -C、Java、Ada、Go以及各类处理器架构上的汇编语言等,所以改名GNU编译器套件(GNU Compiler Collection) 。

下载gcc7.3.0源码

  下载地址:https://mirrors.tuna.tsinghua.edu.cn/gnu/gcc/gcc-7.3.0/gcc-7.3.0.tar.gz


GCC编译

步骤一:安装所需要的环境

  这里肯定要上网了,要是没有上网则只能自己去下载源码包,然后配置、编译和安装三部曲了,而且还得注意版本号,所以最好还是先安装一次查看版本号,再去下载对应版本号的源码,去目标机离线安装。

  下面是configure配置gcc会出现的问题,所以需要先安装依赖库。

  

sudo apt-get install libgmp-dev
sudo apt-get install libmpfr-dev
sudo apt-get install libmpc-dev

  

  这里安装完,然后装的gcc7.5, 不要卸载已有的gcc,查看“入坑一”。

步骤二:下载解压

tar xvf gcc-7.3.0.tar.gz

  

步骤三:配置configure

./configure

  这里要增加c和c++的配置,不然编译出来只有g++了

./configure --enable-checking=release --enable-languages=c,c++ --disable-multilib

  查看 “入坑二”。

  

步骤四:编译make

make -j4

  

  第一次编译后再下执行几次make -j4,最后再执行一次make,确认每个线程都正常跑完(PS:有些错了就停止了,但是被没停止的线程冲掉了,保持这个习惯即可避免疏忽)。

  编译出错。

步骤五:编译出错“fatal error: asm/errno.h: No such file or directory”

  

  引入error.h的头文件,这里查了很多asm文件夹,最后发现只有asm-generic下的才有error.h

sudo find / -name asm

  以下的一些都没有error.h:

  

  只有asm-generic下的才有error.h

sudo ln -s /usr/include/asm-generic /usr/include/asm

  

  然后继续编译,make -j8

  编译出错。

步骤六:编译出错“sanitizer_syscall_generic.inc:15:24: error: ‘__NR_open’ was not declared in this scope”

  

  这里错误实际上是前面带进来的

sudo ln -s /usr/include/asm-generic /usr/include/asm

  是错误的,需要更改为另外一个,这里要先删除,否则ln新建不了:

sudo rm /usr/include/asm
sudo ln -s /usr/include/x86_64-linux-gnu/asm /usr/include/asm
ls /usr/include/asm
ls -l /usr/include/asm

  

  然后继续编译,make -j8

步骤七:编译成功

  

步骤八:安装

sudo make install

  

  

步骤九:查看版本号确认

  


入坑

入坑一:本地需要g++,否则编译报错

问题

  卸载了g++,编译gcc的时候报错:

  

原理

  可能跟交叉编译一样,交叉编译的编译器也是需要一个编译器编译交叉编译器的源码来生成交叉编译器的(只不过最近几年sdk已经自带了交叉编译器了)

解决

  安装gcc,再次编译即可。

入坑二:安装后只有g++,没有gcc

问题

  gcc版本是7.5,g++版本是7.3。

原理

  配置文件需要配置编译c和c++的,默认只有c++的。

解决

  修改配置文件

./configure

  这里要增加c和c++的配置,不然编译出来只有g++

./configure --enable-checking=release --enable-languages=c,c++ --disable-multilib

  然后重新编译走一遍流程解决。

  

相关文章
|
12天前
|
Ubuntu Windows
【Ubuntu/Arm】Ubuntu 系统如何链接有线网络(非虚拟机)?
【Ubuntu/Arm】Ubuntu 系统如何链接有线网络(非虚拟机)?
|
17天前
|
Ubuntu NoSQL 关系型数据库
Ubuntu系统下安装常用软件
Ubuntu系统下安装常用软件
38 0
Ubuntu系统下安装常用软件
|
1月前
|
Ubuntu Linux C语言
Ubuntu下安装vscode,并解决终端打不开vscode的问题
Ubuntu下安装vscode,并解决终端打不开vscode的问题
114 0
|
12天前
|
Ubuntu Linux 网络安全
【ubuntu】MobaXtem远程登录ubuntu系统(或虚拟机)
【ubuntu】MobaXtem远程登录ubuntu系统(或虚拟机)
|
1月前
|
算法 Linux
【Linux笔记】压缩、解压文件的 4 种方式。tar、gzip、gunzip、zip、unzip、7z命令使用方法
【Linux笔记】压缩、解压文件的 4 种方式。tar、gzip、gunzip、zip、unzip、7z命令使用方法
|
18天前
|
Ubuntu 关系型数据库 MySQL
Ubuntu 中apt 安装MySQL数据库
Ubuntu 中apt 安装MySQL数据库
63 0
|
9天前
|
Linux API C语言
FFmpeg开发笔记(一)搭建Linux系统的开发环境
本文指导初学者如何在Linux上搭建FFmpeg开发环境。首先,由于FFmpeg依赖第三方库,可以免去编译源码的复杂过程,直接安装预编译的FFmpeg动态库。推荐网站<https://github.com/BtbN/FFmpeg-Builds/releases>提供适用于不同系统的FFmpeg包。但在安装前,需确保系统有不低于2.22版本的glibc库。详细步骤包括下载glibc-2.23源码,配置、编译和安装。接着,下载Linux版FFmpeg安装包,解压至/usr/local/ffmpeg,并设置环境变量。最后编写和编译简单的C或C++测试程序验证FFmpeg环境是否正确配置。
28 8
FFmpeg开发笔记(一)搭建Linux系统的开发环境
|
12天前
|
Ubuntu Linux 虚拟化
【Linux】ubuntu安装samba服务器
【Linux】ubuntu安装samba服务器
|
30天前
|
Linux
linux驱动开发-点亮第一个led灯
linux驱动开发-点亮第一个led灯
22 0
|
1月前
|
Linux 网络安全 开发工具
【Linux笔记】常用的Linux的指令
【Linux笔记】常用的Linux的指令