Spring+Hibernate+Struts2整合所需要的Jar包-阿里云开发者社区

开发者社区> 数据库> 正文

Spring+Hibernate+Struts2整合所需要的Jar包

简介: struts2.1.6 支持jar包 xwork-2.1.2.jar struts2-core-2.1.6.jar commons-logging-1.0.4.jar freemarker-2.3.13.jar ognl-2.6.11.jar commons-fileupload-1.2.1.jar spring2.5.6支持jar包 spring.jar cglib-no
  1. struts2.1.6 支持jar包
    • xwork-2.1.2.jar
    • struts2-core-2.1.6.jar
    • commons-logging-1.0.4.jar
    • freemarker-2.3.13.jar
    • ognl-2.6.11.jar
    • commons-fileupload-1.2.1.jar
  2. spring2.5.6支持jar包
    • spring.jar
    • cglib-nodep-2.1_3.jar
    • dom4j-1.6.1.jar
    • log4j-1.2.15.jar
    • commons-logging.jar(commons-logging-1.0.4.jar已添加过了)
  3. strust2.1.6整合spring插件支持jar包
    • struts2-spring-plugin-2.1.6.jar(一定要和strust2的版本相同)
  4. hibernate3.3.1支持jar包
    • hibernate3.jar
    • antlr-2.7.6.jar
    • commons-collections-3.1.jar
    • jta-1.1.jar
    • dom4j-1.6.1.jar(已填加)
    • javassist-3.4.GA.jar
    • slf4j-api-1.5.2.jar
    • slf4j-log4j12-1.5.2.jar
  5. 如果使用C3P0数据源实现数据库连接
    • c3p0-0.9.0.4.jar
  6. 如果使用mysql数据库
    • Mysql JDBC驱动: mysql-connector.jar
  7. 如果想用junit测试
    • junit-4.4.jar


补充:该文描述的整和jar文件,几乎是最小项目的jar文件,适用于建立空项目是使用。如果你的项目功能完备,你需要更据具体情况添加jar文件。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

其他文章