开发者社区 > 视觉智能 > 正文

视觉智能平台这个文档PHP SDK 直接调用也报错 能给看看哪里的问题吗?

942bb894e8f54c7b744987bbd9ea1bc2.png 视觉智能平台这个文档https://help.aliyun.com/document_detail/155645.htm?spm=a2c4g.176664.0.0.8a5f764bYaQIIU PHP SDK 直接调用也报错 【Declaration of AlibabaCloud\Tea\OSSUtils\VerifyStream::read($length) must be compatible with GuzzleHttp\Psr7\Stream::read($length)】能给看看哪里的问题吗?

展开
收起
cuicuicuic 2023-04-26 21:15:42 169 0
1 条回答
写回答
取消 提交回答
  • 因目前SDK只支持1.x版本的Psr7,在PHP 8环境中安装需要将Psr7版本降到1.x版本,例如1.9.0版本。具体命令如下:composer require guzzlehttp/psr7 1.9.0 因为psr7依赖guzzlehttp/guzzle,要求guzzlehttp/psr7: ^1.9 || ^2.4,更改版本不会影响SDK使用。

    2023-04-27 10:54:17
    赞同 展开评论 打赏

为开发者提供高易用、普惠的视觉API服务,帮助企业快速建立视觉智能技术应用能力的综合性视觉AI能力平台。适用于数字营销、互联网娱乐、安防、手机应用、泛金融身份认证等行业。

相关产品

  • 视觉智能开放平台
  • 热门讨论

    热门文章

    相关电子书

    更多
    阿里云视觉智能开放平台产品介绍 立即下载
    一个跨平台的云服务SDK需要什么 立即下载
    利用CNN实现无需联网的图像识别 立即下载