开发者社区> 问答> 正文

flink啥时候出 hadoop3.0版本的呀

apache_flink 2019-02-14 15:35:06 1741

转自钉钉群21789141:
flink啥时候出 hadoop3.0版本的呀

流计算
分享到
取消 提交回答
全部回答(2)
  • tinyfear
    2019-07-17 23:28:16

    可以用社区flink1.6+的版本源码重新编译打包,我司部分轻state的job已经正常跑在hadoop3.1 + flink-1.7.1上了,内部测试了下flink1.6也OK;
    低版本打包可能会有部分依赖包不兼容的问题,比如 flink1.3.2 与 hadoop3.1.0的netty依赖;

    0 0
  • apache_flink
    2019-07-17 23:28:16

    成阳:
    blink内部版本使用hadoop 3.0版本的client,从而能使用到一些yarn 3.x才有功能(比如placement constraint)。
    但如果使用hadoop 3.0特有的api后,会导致flink在低版本的hadoop集群中不能正常运行。
    目前大部分yarn用户还是以hadoop 2.6为主,所以目前blink开源版对于hadoop的依赖是2.6及以上版本的。
    如果flink用户不需要hadoop 3.0特有的api的话,编译flink时用hadoop 2.6版本即可。
    我们已经测试过基于hadoop 2.6.5的flink能够正常运行在hadoop 3.x的集群中。

    0 0
添加回答
+ 订阅

大数据计算实践乐园,近距离学习前沿技术

推荐文章
相似问题