POJ-1979,Red and Black(DFS)

简介: POJ-1979,Red and Black(DFS)

Description:


There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.


Write a program to count the number of black tiles which he can reach by repeating the moves described above.  


Input:


The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.


There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.


'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.  


Output:


For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).  


Sample Input:


6 9


....#.


.....#


......


......


......


......


......


#@...#


.#..#.


11 9


.#.........


.#.#######.


.#.#.....#.


.#.#.###.#.


.#.#..@#.#.


.#.#####.#.


.#.......#.


.#########.


...........


11 6


..#..#..#..


..#..#..#..


..#..#..###


..#..#..#@.


..#..#..#..


..#..#..#..


7 7


..#.#..


..#.#..


###.###


...@...


###.###


..#.#..


..#.#..


0 0


Sample Output:


45


59


6


13


解题思路:


如果说,你写搜索的题写的挺多了话,那么这道题可能你看到样例,就能猜到这是一道要用DFS的题,题目的大致意思就是说给你一个图,‘@’代表这个人初始的位置;‘#’代表红色瓷砖,表示不能走;‘.’代表黑色瓷砖,可以走。最后要计算的是遍历走完整幅图,一共可以经过多少块黑色瓷砖。


程序代码:  


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int w,h,ans;
char map[25][25];
int num1[4]={-1,1,0,0};
int num2[4]={0,0,-1,1};
void dfs(int x,int y)
{
  map[x][y]='#';
  ans++;
  for(int i=0;i<4;i++)
  {
    int tx=x+num1[i];
    int ty=y+num2[i];
    if(tx>=0&&tx<h&&ty>=0&&ty<w&&map[tx][ty]=='.')
      dfs(tx,ty);
  }
  return ;
}
int main()
{
  while(cin>>w>>h)
  {
    if(w==0&&h==0)
      break;
    ans=0;
    int x,y;
    for(int i=0;i<h;i++)
      for(int j=0;j<w;j++)
        cin>>map[i][j];
    for(int i=0;i<h;i++)
    {
      for(int j=0;j<w;j++)
      {
        if(map[i][j]=='@')
        {
          x=i;
          y=j;
        }
      }
    }
    dfs(x,y);
    cout<<ans<<endl;
  }
  return 0;
}


相关文章
|
26天前
|
Java
hdu-1312-Red and Black
hdu-1312-Red and Black
17 0
|
11月前
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
61 0
|
C++
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
77 0
|
机器学习/深度学习 Windows
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
82 0
CodeForces - 1469B Red and Blue (前缀和)
CodeForces - 1469B Red and Blue (前缀和)
81 0
hdu 1312 Red and Black(BFS)
hdu 1312 Red and Black(BFS)
126 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
129 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
96 0
Codeforces 833D Red-black Cobweb【树分治】
D. Red-black Cobweb time limit per test:6 seconds memory limit per test:256 megabytes input:standard input output:standard o...
1416 0