POJ 1979 Red and Black(红与黑)

简介:

原文

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

分析

题目中有如下要求:

只能走周围的4个相邻点
只能走黑色点,不能走红色点
一次只能走一点

需要计算的是:能走到的黑色点的和

因为”.“表示黑色点,所以在下面的dfs函数中需要判断当前点为黑色点才可以进行下一步搜索。

和走的方向在于下方代码中定义的direc二维数组。

而其具体的方向等信息,我全都列在下图了。

这里写图片描述

代码

#include <iostream>      
using namespace std;

// 题目中给出的最大宽度和高度
#define MAX_W 20
#define MAX_H 20

// 待输入的宽度和高度以及已走的步数
int W, H;     
int step = 0;

// 待写入的二维数组
char room[MAX_W][MAX_H];
// 顺时针的可走方向
const int direc[4][2] = {
    {0, -1},
    {1,0},
    {0, 1},
    {-1 ,0},
};


int dfs(const int& row, const int& col) {
    // 走过的点
    room[row][col] = '#';
    // 计算步数
    ++step;
    for (int d = 0; d < 4; ++d) {
        int curRow = row + direc[d][1];
        int curCol = col + direc[d][0];
        if (curRow >= 0 && curRow < H && curCol >= 0 && curCol < W && room[curRow][curCol] == '.') {
            dfs(curRow, curCol);
        }
    }
    return step;
}

int main()
{
    bool found;
    while (cin >> W >> H, W > 0) {
        step = 0;
        int col, row;
        // 输入
        for (row = 0; row < H; ++row) {
            for (col = 0; col < W; ++col) {
                cin >> room[row][col];
            }
        }
        found = false;
        // 找到起始点
        for (row = 0; row < H; ++row) {
            for (col = 0; col < W; ++col) {
                if (room[row][col] == '@') {
                    found = true;
                    break;
                }
            }
            if (found) {
                break;
            }                   
        }
        // 开始搜索
        cout << dfs(row, col) << endl;
    }
}
目录
相关文章
|
6月前
|
Java
hdu-1312-Red and Black
hdu-1312-Red and Black
33 0
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
83 0
|
机器学习/深度学习 C++
【PAT甲级 - C++题解】1069 The Black Hole of Numbers
【PAT甲级 - C++题解】1069 The Black Hole of Numbers
76 0
CodeForces - 1469B Red and Blue (前缀和)
CodeForces - 1469B Red and Blue (前缀和)
97 0
hdu 1312 Red and Black(BFS)
hdu 1312 Red and Black(BFS)
144 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
150 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
111 0
Codeforces 833D Red-black Cobweb【树分治】
D. Red-black Cobweb time limit per test:6 seconds memory limit per test:256 megabytes input:standard input output:standard o...
1435 0