hdu-1312-Red and Black

简介: hdu-1312-Red and Black


Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13464    Accepted Submission(s): 8338


Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

 


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 


Sample Input

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 


Sample Output

45 59 6 13

 


Source

Asia 2004, Ehime (Japan), Japan Domestic

 


Recommend

Eddy   |   We have carefully selected several similar problems for you:  1241 1010 1372 1242 1253

 



题目分析:

最简单的dfs   就是让你  从@出发最对能走多少步  可以四个方向走但是遇到#不能走


#include<cstdio>
#include<cstring>
char a[22][22];
int x,y;
int n,m;
int cnt;
void dfs(int x,int y)
{
  if(a[x][y]=='#') return;
  if(x>=1&&x<=m&&y>=1&&y<=n)
  {
      a[x][y]='#';// 把走过的路都标记成墙不能再走了
    cnt++;//  每走一步就加一  
    dfs(x+1,y);// 向下遍历 
    dfs(x-1,y);//  向上遍历
    dfs(x,y-1);//  向左遍历
    dfs(x,y+1);// 向右遍历    就是每个方向都走一遍直到遇到 # 转方向
  }   
}
int main()
{
 
  while(~scanf("%d%d",&n,&m)&&n|m)
  {
    int i,j;
    memset(a,0,sizeof(a));
    for(i=1;i<=m;i++)
    {
      scanf("%s",a[i]+1);// 记住这里一定要加一因为 你的初始位置是  1  1  如果不加仪的话初始位置就         //是1  0了   因为这里选择的是一行一行的输入每行是一个字符串  字符串的首地址就是  0 所以这里要加1  变成 1 1
      for(j=1;j<=n;j++)
      {
        if(a[i][j]=='@')
        {
          x=i;
          y=j;
        }
      }
    }
    cnt=0;
    dfs(x,y);
    printf("%d\n",cnt);
  }
  return 0;
}




目录
相关文章
|
11月前
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
60 0
|
10月前
UVa837 - Light and Transparencies(排序)
UVa837 - Light and Transparencies(排序)
41 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
129 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
96 0
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
89 0