开发者社区> 余二五> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

java+mysql+ruby+rails+nb6_on ubuntu7.10

简介:
+关注继续查看
1 sudo apt-get install sun-java6-jdk 

2 sudo gedit /etc/environment 

3 add two line and save: 
CLASSPATH=/usr/lib/jvm/java-6-sun/lib 
JAVA_HOME=/usr/lib/jvm/java-6-sun 

4 download netbeans-6.0-ruby-linux.sh 

5 double click netbeans-6.0-ruby-linux.sh and select "Run in Terminal"(make sure System->Preference->Appearence->Visual Effect turn to 'None' or you can't see the install botton) 

6 if you want use subversion in Netbeans do this: sudo apt-get install subversion 

7 if you want use MySQL do this: sudo apt-get install mysql-server-5.0 

8 Applications->Add/Remove to install the "MySQL Query Browser" 

9 $ sudo apt-get install ruby rubygems irb ri rdoc ruby1.8-dev build-essential 
$ sudo gem install rails --include-dependencies 
$ export PATH=$PATH:/var/lib/gems/1.8/bin 

10 $ sudo gem install -v=1.2.5 rails 

11 open netbeans and Tools->Options->Ruby, set the Ruby Interpreter "/usr/bin/ruby1.8" 

12 add the socket: /var/run/mysqld/mysqld.sock to the database.yml: 
development: 
adapter: mysql 
database: financing_rails2_development 
username: root 
password: 
host: localhost 
socket: /var/run/mysqld/mysqld.sock 

ref: 
[url]http://blog.donews.com/maverick/archive/200[/url]7/05/22/1167648.aspx 
[url]http://www.qyjohn.net/?p=266[/url] 
http://ubuntuguide.org/wiki/Ubuntu:Gutsy#MySQL 
[url]http://wiki.[/url]rubyonrails.org/rails/pages/RailsOnUbuntu 
[url]https://help.[/url]ubuntu.com/community/RubyOnRails




本文转自 fsjoy1983 51CTO博客,原文链接:http://blog.51cto.com/fsjoy/63816,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
2021再拾ruby以及在centos上安装Ruby3.0 vs code运行ruby 狂踩坑记录
2021再拾ruby以及在centos上安装Ruby3.0 vs code运行ruby 狂踩坑记录
0 0
Centos6 Ruby 1.8.7升级至Ruby 2.3.1的方法
本文章地址:https://www.cnblogs.com/erbiao/p/9117018.html#现在的版本 [root@hd4 /]# ruby --version ruby 1.8.7 (2013-06-27 patchlevel 374) [x86_64-linux] #升级过程 [root@hd4 /]# curl -sSL https://rvm.
1504 0
解决redis在centos自带ruby版本太低问题centos 6.5 ruby环境安装2.2+
redis3.0以上支持集群,自带集群管理工具redis-trib.rb;在搭建集群前,安装ruby环境 ruby安装包下载 安装开发工具 1、命令:yum groupinstall "D...
1329 0
Python学习笔记--在CentOS 6上升级Python至2.7版本
前言: CentOS 6.X上面安装的python默认版本为2.6.6,但是现在很多库都是要求python2.7,因此一个新系统上面要做的第一件事就是升级Python。
761 0
ruby on rails + mysql 开发环境搭建
ror对于初学者来讲,可能最大的困难莫过于开发环境的安装与搭建,今天折腾了大半天基本搞定了,把过程贴在这里,以便初学者少走弯路。 1.安装ruby 1.8.6 打开  http://rubyforge.
1283 0
+关注
文章
问答
文章排行榜
最热
最新
相关电子书
更多
CentOS Nginx PHP JAVA多语言镜像使用手册
立即下载
CentOS Nginx PHP JAVA 多语言镜像使用手
立即下载
PPython高性能计算库--Numba
立即下载