畅通工程,How Many Tables ACM第九天-图论

简介: 下面两题的方法是一样的都是并查集的应用; 并查集的重点就是找到祖先节点的过程。 重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); } 不断地递归,递归到找到自己是自己的祖先为止。
下面两题的方法是一样的都是并查集的应用;
并查集的重点就是找到祖先节点的过程。
重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); }
不断地递归,递归到找到自己是自己的祖先为止。并且把它取接到那个祖先节点上;这样可以节省空间和时间。

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15414    Accepted Submission(s): 7560


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
 
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
 
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy
 


#include <cstdio>
#define maxn 1005
using namespace std;
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d %d",&n,&m);
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - ans;
		printf("%d\n",answer);
	}
	return	0;
}

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32971    Accepted Submission(s): 17391


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

Sample Input
 
     
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
 
     
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 

Source
 

Recommend
JGShining
 

 
 
#include <cstdio>
#include <cstring>

using namespace std;
#define maxn 1005
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m) && n){
		memset(p,0,sizeof(p));
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - 1 - ans;
		printf("%d\n",answer);
	}
	return	0;
}


相关文章
|
6月前
|
数据可视化 算法 Go
【博士每天一篇文献-实验】Exploring the Morphospace of Communication Efficiency in Complex Networks
这篇论文探讨了复杂网络中不同拓扑结构下的通信效率,并使用"效率形态空间"来分析网络拓扑与效率度量之间的关系,得出结论表明通信效率与网络结构紧密相关。
56 3
|
算法
聪明的KK【ACM】
聪明的KK【ACM】
106 0
2020 ICPC Asia Taipei-Hsinchu Site Programming Contest H. Optimization for UltraNet (二分+最小生成树+算贡献)
2020 ICPC Asia Taipei-Hsinchu Site Programming Contest H. Optimization for UltraNet (二分+最小生成树+算贡献)
136 0
|
人工智能
Tianchi x MSU Hackathon - IJCAI 2018 Alimama International Advertising Algorithm Competition
Alibaba Cloud Tianchi will be hosting the IJCAI 2018 Alimama International Advertising Algorithm Competition at Moscow State University in April.
1971 0
Tianchi x MSU Hackathon - IJCAI 2018 Alimama International Advertising Algorithm Competition
|
存储 iOS开发 对象存储
Objective-C 学习第九天
一、 框架: 系统或者第三方事先写好的写很牛X功能的类,把这些类交给我们使用,这些类的集合就叫框架. Foundation框架: 是一个包,有很多类和函数,定义了一些数据类型.
962 0