POJ 1125 Stockbroker Grapevine

简介:
Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions:26859   Accepted: 14868

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10




#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

#define M 1000
int ma[105][105];
int d[105],v[105];
int n;

int  dj(int s)
{
    int i,j;
    memset(v,0,sizeof v);
    for(i=1;i<=n;i++)
        d[i]=ma[s][i];
    v[s]=1;

    for(i=1;i<n;i++)
    {
        int x,mi=M;
        for(j=1;j<=n;j++)
            if(mi>d[j] && !v[j])
            mi=d[x=j];

        v[x]=1;
        for(j=1;j<=n;j++)
            if(d[j]>d[x]+ma[x][j] && !v[j])
            d[j]=d[x]+ma[x][j];
    }

    int ans=-1;
    for(i=1;i<=n;i++)
    {
        if(i==s)   continue;
        if(ans<d[i])    ans=d[i];
    }

    return ans;
}

int main()
{
    while(scanf("%d",&n) && n)
    {
        int i,j,k;
        for(i=1;i<=n;i++)
            for(j=1;j<=i;j++)
            {
                if(i==j)   ma[i][j]=0;
                else    ma[i][j]=ma[j][i]=M;
            }

        for(k=1;k<=n;k++)
        {
            int m,x,t;
            scanf("%d",&m);
            for(i=1;i<=m;i++)
            {
                scanf("%d%d",&x,&t);
                ma[k][x]=t;
            }
        }

        int ans=M,s=0;
        for(i=1;i<=n;i++)
        {
            int h=dj(i);
            if(h==-1)   {ans=-1;break;}
            else   if(ans>h)
                ans=h,s=i;
        }

        if(ans != M)  printf("%d %d\n",s,ans);
        else   printf("disjoint\n");
    }

    return 0;
}








本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5061222.html,如需转载请自行联系原作者

相关文章
|
机器学习/深度学习
棋盘问题 POJ 1321
总时间限制:  1000ms 内存限制:  65536kB 描述 在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。
1186 0
|
人工智能 算法 BI
poj 2192 Zipper
题目链接:http://poj.org/problem?id=2192 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 18658   Accepted: 6651 Description Given ...
981 0
|
测试技术
POJ 1001
此题用最朴素的思路实现即可,需模拟加法器,乘法器,最烦人的地方是特殊情形,如末位是小数点(12.^2=144,取小数点),整数末位是0(100^2=10000),0次幂,测试用例可能超出题目中说的范围,可能包含0次幂(100.0^0=0, 0.10^1=0.1)。
756 0
poj 3620
题意:给出一个矩阵,其中有些格子干燥、有些潮湿。       如果一个潮湿的格子的相邻的四个方向有格子也是潮湿的,那么它们就可以构成更大       的湖泊,求最大的湖泊。       也就是求出最大的连在一块儿的潮湿的格子的数目。
578 0
POJ 2027 No Brainer
Problem Description Zombies love to eat brains. Yum. Input The first line contains a single integer n indicating the number of data sets.
871 0
|
机器学习/深度学习 Windows
|
消息中间件 人工智能 JavaScript