POJ-1611,The Suspects

简介: POJ-1611,The Suspects

Problem Description:


Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.


Input:


The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.


Output:


For each case, output the number of suspects in one line.


Sample Input:


100 4


2 1 2


51013111214


2 0 1


2 99 2


200 2


1 5


5 1 2 3 4 5


1 0


0 0


Sample Output:


4


1


1


解题思路:


因为题目中说最初的学生0被视为嫌疑犯,所以只需要寻找根节点与0相等的即可。


程序代码:  


#include<stdio.h>
int f[30001];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
  return ;
}
int main()
{
  int n,m,i,j,k,x,y,sum;
  while(~scanf("%d %d",&n,&m))
  {
    if(n==0&&m==0)
      break;
    for(i=0;i<n;i++)
      f[i]=i;
    while(m--)
    {
      scanf("%d %d",&k,&x);
      for(j=1;j<k;j++)
      {
        scanf("%d",&y);
        merge(x,y);
      }
    }
    sum=1;
    for(i=1;i<n;i++)
    {
      if(getf(i)==getf(0))
        sum++;
    }
    printf("%d\n",sum);
  }
  return 0;
}


相关文章
|
7月前
|
算法
Highways(POJ—2485)
Highways(POJ—2485)
|
人工智能 机器学习/深度学习
|
算法 数据建模 机器学习/深度学习
|
机器学习/深度学习
A-POJ-1321 棋盘问题
Description 在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。
940 0
|
算法 存储
POJ 1014 Dividing 解答
题目详见http://poj.org/problem?id=1014 看到这道题第一反应便知道它是一道类似背包问题的题,  解法我自然而然得从背包问题的解法入手,  网上查了查,  背包问题的基本题型是01背包, 即每种...
1052 0
poj 2912 Rochambeau
点击打开链接poj 2912 思路: 带权并查集 分析: 1 有n个小孩玩游戏,里面有一个入是裁判,剩下的人分为三组。现在我们既不知道裁判是谁也不知道分组的情况。
957 0