POJ 2524 :Ubiquitous Religions

简介:
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions:23171
Accepted: 11406

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7


额。。难道题单错了?。。

。我一看就是并查集。

。所以就这么水过了。。


并查集一A水过


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<sstream>
#include<cmath>

using namespace std;

#define M 100500
int p[M];
int n, m;

void start()
{
    for(int i=1; i<=n; i++)
        p[i] = i;
}

int find(int x)
{
    return p[x] == x ?

x : p[x] = find( p[x] ); } void Kruskal(int x, int y) { int xx = find(x); int yy = find(y); if(xx!=yy) p[yy] = xx; } int main() { int cas = 0; while(scanf("%d%d", &n, &m) &&n &&m) { cas++; start(); int ans = 0; for(int i=1; i<=m; i++) { int x; int y; scanf("%d%d", &x, &y); Kruskal(x, y); } for(int i=1; i<=n; i++) { if( p[i]==i ) ans++; } printf("Case %d: %d\n", cas, ans); } return 0; }









本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5078519.html,如需转载请自行联系原作者


相关文章
POJ 1012 Joseph
Joseph Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 53862   Accepted: 20551 Description The Joseph's problem is notoriously known.
817 0
poj 3620
题意:给出一个矩阵,其中有些格子干燥、有些潮湿。       如果一个潮湿的格子的相邻的四个方向有格子也是潮湿的,那么它们就可以构成更大       的湖泊,求最大的湖泊。       也就是求出最大的连在一块儿的潮湿的格子的数目。
552 0
poj-1006-Biorhythms
Description 人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。
587 0
poj-2551-ones
Description Given any integer 0
748 0
|
存储 索引